summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGergely Nagy <algernon@balabit.hu>2012-04-13 14:00:16 +0200
committerGergely Nagy <algernon@balabit.hu>2012-04-13 14:00:16 +0200
commitfa74ad61a0f7ea5603128da6e5fd673019a4687b (patch)
tree5314ccdd24d0e77813ecb343dd9153762ebdb2ad /configure.ac
parent6a88617d83a94f66825811dc0e782b1e740179d7 (diff)
downloadlibumberlog-fa74ad61a0f7ea5603128da6e5fd673019a4687b.tar.gz
libumberlog-fa74ad61a0f7ea5603128da6e5fd673019a4687b.tar.xz
libumberlog-fa74ad61a0f7ea5603128da6e5fd673019a4687b.zip
configure updates
Check for a few more headers, functions and types. Signed-off-by: Gergely Nagy <algernon@balabit.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4174f66..4717dd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,11 +35,11 @@ AC_HEADER_STDC
dnl ***************************************************************************
dnl Header checks
dnl ***************************************************************************
-AC_CHECK_HEADERS([syslog.h dlfcn.h limits.h])
+AC_CHECK_HEADERS([syslog.h dlfcn.h limits.h wchar.h])
dnl ***************************************************************************
dnl Checks for libraries
-AC_CHECK_FUNCS([gethostname strdup __syslog_chk])
+AC_CHECK_FUNCS([gethostname strdup memset __syslog_chk])
dnl The dlopen() function is in the C library for *BSD and in
dnl libdl on GLIBC-based systems
@@ -62,8 +62,11 @@ dnl ***************************************************************************
dnl misc features to be enabled
dnl ***************************************************************************
AC_C_INLINE
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
AC_TYPE_PID_T
AC_TYPE_UID_T
+AC_TYPE_SIZE_T
AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [package name])
AC_DEFINE_UNQUOTED(VERSION, "$VERSION", [version number])