summaryrefslogtreecommitdiffstats
path: root/sigmod/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <MathStuf@gmail.com>2008-11-25 17:30:06 -0500
committerBen Boeckel <MathStuf@gmail.com>2008-11-25 17:30:06 -0500
commit59e8dcc77727ecdec81412fd3a9dd3c3d3f76362 (patch)
tree15668107077f9ac824628b258368cd8942b5004c /sigmod/CMakeLists.txt
parent0350d36872d4ab01eba7a4890f0d24e5217b7e22 (diff)
downloadsigen-59e8dcc77727ecdec81412fd3a9dd3c3d3f76362.tar.gz
sigen-59e8dcc77727ecdec81412fd3a9dd3c3d3f76362.tar.xz
sigen-59e8dcc77727ecdec81412fd3a9dd3c3d3f76362.zip
Fixed up the linking of the libraries
Diffstat (limited to 'sigmod/CMakeLists.txt')
-rw-r--r--sigmod/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/sigmod/CMakeLists.txt b/sigmod/CMakeLists.txt
index 9bfdd57f..5ec1cff4 100644
--- a/sigmod/CMakeLists.txt
+++ b/sigmod/CMakeLists.txt
@@ -95,7 +95,11 @@ SET_TARGET_PROPERTIES(sigmod
)
TARGET_LINK_LIBRARIES(sigmod
${QT_QTCORE_LIBRARY}
- ${QT_QTGUI_LIBRARY}
+ ${QT_QTXML_LIBRARY}
+ sigcore
+)
+TARGET_LINK_LIBRARIES(sigmod LINK_INTERFACE_LIBRARIES
+ ${QT_QTCORE_LIBRARY}
${QT_QTXML_LIBRARY}
sigcore
)