summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <MathStuf@gmail.com>2008-11-25 16:27:03 -0500
committerBen Boeckel <MathStuf@gmail.com>2008-11-25 16:27:03 -0500
commit519786d4e7f515f640dfdea22a13b487f5774550 (patch)
tree340b9fbb0bea6fd735300364e9071f3e6a21dabc /CMakeLists.txt
parent780df53c766ebe016e5ae3b728b02d954023feac (diff)
downloadsigen-519786d4e7f515f640dfdea22a13b487f5774550.tar.gz
sigen-519786d4e7f515f640dfdea22a13b487f5774550.tar.xz
sigen-519786d4e7f515f640dfdea22a13b487f5774550.zip
Doxygen is better suited to CMake now
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0aa1420a..3400a9c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,8 @@ FIND_PACKAGE(Phonon)
FIND_PACKAGE(QCA2)
# FIND_PACKAGE(LibKDEGames)
+INCLUDE(doxygen.cmake)
+
SET(SIGEN_VERSION_MAJOR 0)
SET(SIGEN_VERSION_MINOR 0)
SET(SIGEN_VERSION_RELEASE 2)
@@ -81,6 +83,11 @@ IF (KDE4_FOUND)
)
ENDIF (KDE4_FOUND)
+IF (DOXYGEN_FOUND)
+ CREATE_DOXYGEN(${DOCUMENTATION_OUTPUT_PATH} ${CMAKE_SOURCE_DIR}/sigcore sigcore)
+ CREATE_DOXYGEN(${DOCUMENTATION_OUTPUT_PATH} ${CMAKE_SOURCE_DIR}/sigmod sigmod ${DOCUMENTATION_OUTPUT_PATH}/sigcore.tag)
+ENDIF (DOXYGEN_FOUND)
+
INSTALL(
FILES
DISCLAIMER