summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <MathStuf@gmail.com>2008-11-30 11:54:51 -0500
committerBen Boeckel <MathStuf@gmail.com>2008-11-30 11:54:51 -0500
commit2fe921caa1eef7c4d1be4cdd884d288deb47cf57 (patch)
tree193f046852914a0ff37dea0f444f26a56a7e9159 /CMakeLists.txt
parente37c565c5461cb28d7fe9672eae2f99726122a7a (diff)
downloadsigen-2fe921caa1eef7c4d1be4cdd884d288deb47cf57.tar.gz
sigen-2fe921caa1eef7c4d1be4cdd884d288deb47cf57.tar.xz
sigen-2fe921caa1eef7c4d1be4cdd884d288deb47cf57.zip
Fixed the exporting with the libraries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07e457eb..ed7ac673 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,6 +98,19 @@ IF (DOXYGEN_FOUND AND UNIX)
ENDIF (DOXYGEN_FOUND AND UNIX)
INSTALL(
+ EXPORT
+ sigen_EXPORTS
+ NAMESPACE
+ sigen_
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/${DATA_INSTALL_DIR}/cmake/modules
+ FILE
+ SigenExportedLibraryTargets.cmake
+ COMPONENT
+ development
+)
+
+INSTALL(
FILES
DISCLAIMER
LICENSE