summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt84
1 files changed, 84 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..64ad8d7
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,84 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.4)
+
+PROJECT(emudb)
+
+FIND_PACKAGE(Qt4 REQUIRED)
+INCLUDE(${QT_USE_FILE})
+
+FIND_PACKAGE(KDE4 REQUIRED)
+
+SET(EXECUTABLE_OUTPUT_PATH
+ ${PROJECT_BINARY_DIR}/bin
+)
+SET(DOCUMENTATION_OUTPUT_PATH
+ ${PROJECT_BINARY_DIR}/doc
+)
+
+INCLUDE_DIRECTORIES(
+ ${QT_INCLUDE_DIR}
+ ${KDE4_INCLUDE_DIR}
+ ${KDE4_INCLUDE_DIR}/KDE
+)
+
+SET(emudb_MOC_HEADERS
+ EmuDB.h
+ Emulator.h
+ EmulatorEditor.h
+ Execute.h
+ Profile.h
+ Rom.h
+ RomEditor.h
+ RomLibrary.h
+ RomType.h
+ RomTypeEditor.h
+)
+QT4_WRAP_CPP(emudb_MOC_SRCS ${emudb_MOC_HEADERS})
+SET(emudb_HEADERS
+ EmuDBConfig.h
+ RomModel.h
+)
+SET(emudb_DEVEL
+ ${emudb_MOC_HEADERS}
+ ${emudb_HEADERS}
+)
+SET(emudb_SRCS
+ EmuDB.cpp
+ EmuDBConfig.cpp
+ Emulator.cpp
+ EmulatorEditor.cpp
+ Execute.cpp
+ Profile.cpp
+ Rom.cpp
+ RomEditor.cpp
+ RomLibrary.cpp
+ RomModel.cpp
+ RomType.cpp
+ RomTypeEditor.cpp
+ main.cpp
+)
+
+ADD_EXECUTABLE(emudb
+ ${emudb_SRCS}
+ ${emudb_MOC_SRCS}
+)
+TARGET_LINK_LIBRARIES(emudb
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${KDE4_KDECORE_LIBRARY}
+ ${KDE4_KDEUI_LIBRARY}
+ ${KDE4_KIO_LIBRARY}
+)
+
+INCLUDE(doxygen.cmake)
+
+INSTALL(
+ TARGETS emudb
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
+ COMPONENT runtime
+)
+
+INSTALL(
+ FILES ${emudb_DEVEL}
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/include/${CMAKE_PROJECT_NAME}
+ COMPONENT development
+)