summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-01-25 10:57:54 -0500
committerJakub Hrozek <jhrozek@redhat.com>2013-01-29 16:18:28 +0100
commit9d096f42802208d6cb54ab25a2e9cc90925f84c7 (patch)
tree1ed86f2ea4f92c1cea184da4739dfea1320c79a7 /configure.ac
parentcfcfa9bd014a7717821c98262a11772c8e79c13e (diff)
downloadsssd-9d096f42802208d6cb54ab25a2e9cc90925f84c7.tar.gz
sssd-9d096f42802208d6cb54ab25a2e9cc90925f84c7.tar.xz
sssd-9d096f42802208d6cb54ab25a2e9cc90925f84c7.zip
TOOLS: Compile on old platforms such as RHEL5
Provides compatible declarations for modern file management functions such as futimens or opening with the O_CLOEXEC flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2cde25174..9245ae7c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,10 @@ AC_CHECK_FUNCS([ pthread_mutexattr_setrobust \
pthread_mutex_consistent_np ])
LIBS=$SAVE_LIBS
+# Check for presence of modern functions for setting file timestamps
+AC_CHECK_FUNCS([ utimensat \
+ futimens ])
+
#Check for PAM headers
AC_CHECK_HEADERS([security/pam_appl.h security/pam_misc.h security/pam_modules.h],
[AC_CHECK_LIB(pam, pam_get_item, [ PAM_LIBS="-lpam" ], [AC_MSG_ERROR([PAM must support pam_get_item])])],