summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Lipovsky <janlipovsky@gmail.com>2010-05-18 15:47:39 +0200
committerJan Lipovsky <janlipovsky@gmail.com>2010-05-18 15:47:39 +0200
commitb282327da5b515ce3288b1084bf1e21cf01c49af (patch)
tree6780b93a2fce034576d1659fe0ea889ea62bc75d /configure.ac
parentedce1bc175adbd9941f17b73ae2d94fd5ffede93 (diff)
downloadsfshare-b282327da5b515ce3288b1084bf1e21cf01c49af.tar.gz
sfshare-b282327da5b515ce3288b1084bf1e21cf01c49af.tar.xz
sfshare-b282327da5b515ce3288b1084bf1e21cf01c49af.zip
Autotools init
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac61
1 files changed, 61 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100755
index 0000000..76a486b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,61 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.63])
+AC_INIT([Simple File Share], [0.1.0], [janlipovsky@gmail.com])
+AM_INIT_AUTOMAKE([Simple File Share], [0.1.0])
+
+# Checks for programs.
+AC_PROG_CC
+
+PKG_CHECK_MODULES(GLIB, glib-2.0)
+AC_SUBST([GLIB_CFLAGS])
+AC_SUBST([GLIB_LIBS])
+
+PKG_CHECK_MODULES(GTK, gtk+-2.0)
+AC_SUBST([GTK_CFLAGS])
+AC_SUBST([GTK_LIBS])
+
+PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1)
+AC_SUBST([DBUS_GLIB_CFLAGS])
+AC_SUBST([DBUS_GLIB_LIBS])
+
+PKG_CHECK_MODULES(POLKIT, polkit-gtk-1)
+AC_SUBST([POLKIT_CFLAGS])
+AC_SUBST([POLKIT_LIBS])
+
+PKG_CHECK_MODULES(NAUTILUS, libnautilus-extension)
+AC_SUBST([NAUTILUS_CFLAGS])
+AC_SUBST([NAUTILUS_LIBS])
+
+
+#AC_CHECK_LIB(gtk-x11-2.0, gtk_init, [], AC_MSG_ERROR([gtk+-2.0 is required for this program]))
+
+#AC_CHECK_LIB(glib-2.0, g_string_new, [], AC_MSG_ERROR([glib-2.0 is required for this program]))
+
+#AC_CHECK_LIB([nautilus-extension], [nautilus_file_info_get_file_type], [], AC_MSG_ERROR([libnautilus-extension is required for this program]))
+
+#AC_CHECK_LIB([dbus-glib-1], [dbus_g_proxy_call], [], AC_MSG_ERROR([dbus-glib-1 is required for this program]))
+
+#AC_CHECK_LIB([polkit-gtk-1], [polkit_authority_check_authorization_finish], [], AC_MSG_ERROR([polkit-gtk-1 is required for this program]))
+
+# Checks for header files.
+AC_CHECK_HEADERS([stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_INLINE
+
+# Checks for library functions.
+AC_CHECK_FUNCS([strstr])
+
+AC_CONFIG_FILES([Makefile
+ sfshare-daemon/Makefile
+ sfshare-daemon/src/Makefile
+ sfshare-daemon/data/Makefile
+ sfshare-gui/Makefile
+ sfshare-gui/src/Makefile
+ sfshare-gui/data/Makefile])
+
+# nautilus-plugin/src/Makefile
+
+AC_OUTPUT