summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 848930d..2fd7895 100755
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,16 @@ if test "x$HAVE_PKGCONFIG" = "xno"; then
fi
+dnl Check for ncpmount first
+AC_CHECK_PROG(HAVE_NCPMOUNT, ncpmount, yes, no)
+AC_PATH_PROG(NCPMOUNT_PATH, ncpmount, no)
+
+dnl Give error and exit if we don't have ncpmount
+if test "x$HAVE_NCPMOUNT" = "xno"; then
+ AC_MSG_ERROR(You need to have ncpmount (ncpfs) installed !)
+fi
+
+
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.26.0)
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
@@ -49,12 +59,10 @@ AC_SUBST(WARN_CFLAGS)
# Checks for header files.
-#AC_CHECK_HEADERS([gtk/gtk.h locale.h libintl.h])
+AC_CHECK_HEADERS([locale.h libintl.h])
# Checks for typedefs, structures, and compiler characteristics.
-#AC_C_INLINE
-
-#
+AC_C_INLINE
AC_CONFIG_FILES([Makefile