summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Lipovský <janlipovsky@gmail.com>2011-01-03 20:01:25 +0100
committerJan Lipovský <janlipovsky@gmail.com>2011-01-03 20:01:25 +0100
commit71f842cc7017d3407254d41e85e933fe1e8122d3 (patch)
treea73b7a06cfd110b10814de731b89fa59bc7b15ef /configure.ac
parent59ca97a935c681628a79f16c5f1501c799b59b7c (diff)
downloadgncpmount-71f842cc7017d3407254d41e85e933fe1e8122d3.tar.gz
gncpmount-71f842cc7017d3407254d41e85e933fe1e8122d3.tar.xz
gncpmount-71f842cc7017d3407254d41e85e933fe1e8122d3.zip
Deprecated code cleaned; Added Autotools and czech translation;
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac65
1 files changed, 65 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100755
index 0000000..848930d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,65 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ([2.63])
+AC_INIT([gncpmount], [0.0.3], [janlipovsky@gmail.com])
+AM_INIT_AUTOMAKE([1.9 tar-ustar])
+
+# Checks for programs.
+AC_C_CONST
+AC_ISC_POSIX
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AM_PROG_CC_C_O
+AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT_VERSION([0.18.1])
+
+
+dnl Check for pkgconfig first
+AC_CHECK_PROG(HAVE_PKGCONFIG, pkg-config, yes, no)
+AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+
+dnl Give error and exit if we don't have pkgconfig
+if test "x$HAVE_PKGCONFIG" = "xno"; then
+ AC_MSG_ERROR(you need to have pkgconfig installed !)
+fi
+
+
+PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.26.0)
+AC_SUBST(GLIB_CFLAGS)
+AC_SUBST(GLIB_LIBS)
+
+PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.22.0)
+AC_SUBST(GTK_CFLAGS)
+AC_SUBST(GTK_LIBS)
+
+PKG_CHECK_MODULES(GDK_PIXBUF, gdk-pixbuf-2.0)
+AC_SUBST(GDK_CFLAGS)
+AC_SUBST(GDK_LIBS)
+
+
+
+
+DISABLE_DEPRECATED_CFLAGS=" -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED"
+AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
+
+dnl WARN_CFLAGS="-Wall -Werror"
+WARN_CFLAGS="-Wall"
+AC_SUBST(WARN_CFLAGS)
+
+
+# Checks for header files.
+#AC_CHECK_HEADERS([gtk/gtk.h locale.h libintl.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+#AC_C_INLINE
+
+#
+
+
+AC_CONFIG_FILES([Makefile
+ po/Makefile.in
+ src/Makefile])
+
+AC_OUTPUT
+