summaryrefslogtreecommitdiffstats
path: root/mesa.spec
diff options
context:
space:
mode:
authorIgor Gnatenko <i.gnatenko.brain@gmail.com>2014-08-08 11:30:31 +0200
committerIgor Gnatenko <i.gnatenko.brain@gmail.com>2014-08-08 11:30:31 +0200
commitf098f029baad1d9041d1337b9aa3d40b697fb534 (patch)
tree55577b75399c8789918523bc3389f61e78e352f2 /mesa.spec
parentad42db06b8bb2f549f62c129e69ceaade9e031bf (diff)
downloadmesa-f098f029baad1d9041d1337b9aa3d40b697fb534.tar.gz
mesa-f098f029baad1d9041d1337b9aa3d40b697fb534.tar.xz
mesa-f098f029baad1d9041d1337b9aa3d40b697fb534.zip
fix freedreno files
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Diffstat (limited to 'mesa.spec')
-rw-r--r--mesa.spec399
1 files changed, 3 insertions, 396 deletions
diff --git a/mesa.spec b/mesa.spec
index df52575..f67e62c 100644
--- a/mesa.spec
+++ b/mesa.spec
@@ -525,7 +525,8 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/dri/i965_dri.so
%endif
%if 0%{?with_freedreno}
-%{_libdir}/dri/freedreno_dri.so
+%{_libdir}/dri/kgsl_dri.so
+%{_libdir}/dri/msm_dri.so
%endif
%{_libdir}/dri/nouveau_dri.so
%if 0%{?with_vmware}
@@ -673,401 +674,7 @@ rm -rf $RPM_BUILD_ROOT
# git log old_commit_sha..new_commit_sha --format="- %H: %s (%an)"
%changelog
* Wed Aug 06 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.3-0.devel.2.c40d7d6d948912a4d51cbf8f0854cf2ebe916636
-- dri/xmlconfig: s/uint/unsigned int/ (Vinson Lee)
-- mesa include stdint.h in formats.h (Brian Paul)
-- mesa/texstore: Add a generic rgba integer texture upload path (Jason Ekstrand)
-- mesa/texstore: Add a generic float/normalized rgba texture upload path (Jason Ekstrand)
-- mesa/texstore: Use _mesa_swizzle_and_convert when possible (Jason Ekstrand)
-- main/texstore: Split texture storage into three functions (Jason Ekstrand)
-- mesa/format_utils: Add a function to convert a mesa_format to an array format (Jason Ekstrand)
-- mesa/format_utils: Add a general format conversion function (Jason Ekstrand)
-- mesa/imports: Add a _mesa_half_is_negative helper function (Jason Ekstrand)
-- mesa/formats: Add layout and swizzle information (Jason Ekstrand)
-- mesa/formats: Remove IndexBits (Jason Ekstrand)
-- mesa/formats: Autogenerate the format_info structure from a CSV file (Jason Ekstrand)
-- mesa/main: Add python code to generate the format_info structure (Jason Ekstrand)
-- mesa: Add python to parse the formats CSV file (Jason Ekstrand)
-- mesa: Add a format description CSV file (Jason Ekstrand)
-- util/tests/hash_table: Link against libmesautil instead of libmesa (Jason Ekstrand)
-- st/mesa: adjust Z coordinates for quad clearing (Brian Paul)
-- mesa: make vertex array type error checking a little more efficient (Brian Paul)
-- glsl_to_tgsi: Fix typo shader_program -> shader (Michel Dänzer)
-- mesa: update wglext.h to version 20140630 (Brian Paul)
-- mesa: update glxext.h to version 20140725 (Brian Paul)
-- mesa: update glext.h to version 20140725 (Brian Paul)
-- meta: Disable dithering during glBlitFramebuffer (Neil Roberts)
-- libgl-xlib: drop duplicate mesautil from scons build (Emil Velikov)
-- llvmpipe/tests: automake: link against libmesautil.la (Emil Velikov)
-- gallium/tests: automake: link against libmesautil.la (Emil Velikov)
-- targets/omx: automake: link against libmesautil.la (Emil Velikov)
-- targets/xvmc: automake: link against libmesautil.la (Emil Velikov)
-- targets/clover: link against libmesautil.la (Jan Vesely)
-- gallivm: Fix build with latest LLVM (Jan Vesely)
-- targets/dri: link with mesautil (Roland Scheidegger)
-- gallium/docs: Document TEX2/TXL2/TXB2 instructions and fix up other tex doc (Roland Scheidegger)
-- gallivm: fix cube map array (and cube map shadow with bias) handling (Roland Scheidegger)
-- llvmpipe: implement support for cube map arrays (Roland Scheidegger)
-- egl: Fix OpenGL ES version checks in _eglParseContextAttribList() (Anuj Phogat)
-- meta: Fix datatype computation in get_temp_image_type() (Anuj Phogat)
-- meta: Move the call to _mesa_get_format_datatype() out of switch (Anuj Phogat)
-- meta: Use _mesa_get_format_bits() to get the GL_RED_BITS (Anuj Phogat)
-- meta: Initialize the variable in declaration statement (Anuj Phogat)
-- mesa: Allow GL_TEXTURE_CUBE_MAP target with compressed internal formats (Anuj Phogat)
-- mesa: Add gles3 condition for normalized internal formats in glCopyTexImage*() (Anuj Phogat)
-- mesa: Add utility function _mesa_is_enum_format_unorm() (Anuj Phogat)
-- mesa: Add gles3 error condition for GL_RGBA10_A2 buffer format in glCopyTexImage*() (Anuj Phogat)
-- mesa: Add a gles3 error condition for sized internalformat in glCopyTexImage*() (Anuj Phogat)
-- mesa: Add a helper function _mesa_is_enum_format_unsized() (Anuj Phogat)
-- mesa: Don't allow snorm internal formats in glCopyTexImage*() in GLES3 (Anuj Phogat)
-- mesa: Add utility function _mesa_is_enum_format_snorm() (Anuj Phogat)
-- mesa: Fix condition for using compressed internalformat in glCompressedTexImage3D() (Anuj Phogat)
-- mesa: Add error condition for using compressed internalformat in glTexStorage3D() (Anuj Phogat)
-- mesa: Turn target_can_be_compressed() in to a utility function (Anuj Phogat)
-- mesa: Fix error condition for valid texture targets in glTexStorage* functions (Anuj Phogat)
-- glsl: Rebuild the symbol table without unreachable symbols (Ian Romanick)
-- glsl: Only create one ir_function for a given name. (Kenneth Graunke)
-- glsl: Make it possible to ignore built-ins when matching signatures. (Kenneth Graunke)
-- mesa: Actually use the Mesa IR optimizer for ARB programs. (Kenneth Graunke)
-- glsl: Do not add extra padding to structures (Ian Romanick)
-- glsl: Correctly determine when the field of a UBO is row-major (Ian Romanick)
-- linker: Use the matrix layout information in ir_variable and glsl_type for UBO layout (Ian Romanick)
-- glsl: Track matrix layout of variables using two bits (Ian Romanick)
-- glsl: Also track matrix layout information into structures (Ian Romanick)
-- glsl: Track matrix layout of structure fields using two bits (Ian Romanick)
-- glsl: Correctly load columns of a row-major matrix (Ian Romanick)
-- linker: Add padding after the last field of a structure (Ian Romanick)
-- linker: Add a last_field parameter to various program_resource_visitor methods (Ian Romanick)
-- mesa: Do not list inactive block members as active (Ian Romanick)
-- glsl: Do not eliminate 'shared' or 'std140' blocks or block members (Ian Romanick)
-- glsl: Use the without_array predicate to simplify some code (Ian Romanick)
-- glsl: Add without_array type predicate (Ian Romanick)
-- glsl: Use constant_expression_value instead of as_constant (Ian Romanick)
-- targets/graw-gdi: link with mesautil, not mesautils (Brian Paul)
-- wmesa: link with mesautil (Brian Paul)
-- osmesa: link with mesautil (Brian Paul)
-- targets/libgl-gdi: link with mesautil (Brian Paul)
-- targets/egl-static: link with libmesautil.la (Brian Paul)
-- mesa/x86: put code in braces to silence declarations after code warning (Brian Paul)
-- src/Makefile.am: Move gtest before util (Jason Ekstrand)
-- util: include c99_compat.h in format_srgb.h to get 'inline' definition (Brian Paul)
-- util: include c99_compat.h in hash_table.h to get 'inline' definition (Brian Paul)
-- targets/vdpau: link with libmesautil.la to fix build breakage (Brian Paul)
-- xlib: fix missing mesautil build breakage (Brian Paul)
-- svga: SVGA_3D_CMD_BIND_GB_SHADER needs to reserve two relocations. (Matthew McClure)
-- gallium: Add libmesautil dependency to gdm and xa targets (Jason Ekstrand)
-- mesa/main: Use the RGB <-> sRGB conversion functions in libmesautil (Jason Ekstrand)
-- gallium: Move sRGB <-> RGB handling to libmesautil (Jason Ekstrand)
-- util: Gather some common macros (Jason Ekstrand)
-- util: Move the open-addressing linear-probing hash_table to src/util. (Kenneth Graunke)
-- util: Move ralloc to a new src/util directory. (Kenneth Graunke)
-- mesa/SConscript: Use Makefile.sources instead of duplicating the file lists (Jason Ekstrand)
-- targets/dri: resolve the scons build (Emil Velikov)
-- mesa/st: Fix compiler warnings (Jan Vesely)
-- gallium: Fix compiler warning. (Jan Vesely)
-- glsl: fix switch statement default case regressions (Tapani Pälli)
-- st/dri: Fix driver loading if swrast isn't built (Aaron Watry)
-- mesa/st: only convert AND(a, NOT(b)) into MAD when not using native integers (Ilia Mirkin)
-- Remove XA state tracker support for Radeon (Marek Olšák)
-- docs: Import 10.2.5 release notes, add news item. (Carl Worth)
-- mesa/st: add support for dynamic ubo selection (Ilia Mirkin)
-- i965: Delete stale "pre-gen4" comment in texture validation code. (Kenneth Graunke)
-- i965: Delete sampler state structures. (Kenneth Graunke)
-- i965: Replace sizeof(struct gen7_sampler_state) with the size itself. (Kenneth Graunke)
-- i965: Drop sizeof(struct brw_sampler_state) from estimated prim size. (Kenneth Graunke)
-- i965: Make BLORP use brw_emit_sampler_state(). (Kenneth Graunke)
-- i965: Delete redundant sampler state dumping code. (Kenneth Graunke)
-- i965: Make some brw_sampler_state.c functions static again. (Kenneth Graunke)
-- i965: Stop using gen7_update_sampler_state; rm gen7_sampler_state.c. (Kenneth Graunke)
-- i965: Make brw_update_sampler_state use 8 bits for LOD fields on Gen7+. (Kenneth Graunke)
-- i965: Make brw_update_sampler_state() use brw_emit_sampler_state(). (Kenneth Graunke)
-- i965: Introduce a function to emit a SAMPLER_STATE structure. (Kenneth Graunke)
-- i965: Add const to upload_default_color's sampler parameter. (Kenneth Graunke)
-- i965: Add #defines for SAMPLER_STATE fields. (Kenneth Graunke)
-- i965: Convert wrap mode #defines to an enum. (Kenneth Graunke)
-- i965: Delete gen7_upload_sampler_state_table and vtable mechanism. (Kenneth Graunke)
-- i965: Make brw_upload_sampler_state_table handle Gen7+ as well. (Kenneth Graunke)
-- i965: Shift brw_upload_sampler_state_table away from structures. (Kenneth Graunke)
-- i965: Push computation for sampler state batch offsets up a level. (Kenneth Graunke)
-- i965: Drop unused 'ss_index' parameter from gen7_update_sampler_state. (Kenneth Graunke)
-- i965: Stop storing sdc_offset in brw_stage_state. (Kenneth Graunke)
-- i965: Drop the degenerate brw_sampler_default_color structure. (Kenneth Graunke)
-- i965: Write a better file comment for brw_sampler_state.c. (Kenneth Graunke)
-- i965: Rename brw_wm_sampler_state.c to brw_sampler_state.c. (Kenneth Graunke)
-- i965/blorp: Don't set min_mag_neq bit in Gen6 SAMPLER_STATE. (Kenneth Graunke)
-- define GL_OES_standard_derivatives if extension is supported (Kevin Rogovin)
-- llvmpipe: don't store number of layers per level (Roland Scheidegger)
-- llvmpipe: integrate memory allocation into llvmpipe_texture_layout (Roland Scheidegger)
-- llvmpipe: get rid of impossible code in alloc_image_data (Roland Scheidegger)
-- i965/miptree: Layout 1D Array as 2D Array with height of 1 (Jordan Justen)
-- r600g: Implement gpu_shader5 textureGather (Glenn Kennard)
-- mesa: Add missing atomic buffer bindings and unbindings (Aditya Atluri)
-- r600g/radeonsi: Prefer VRAM for CPU -> GPU streaming buffers (Michel Dänzer)
-- r600g/radeonsi: Reduce or even drop special treatment of persistent mappings (Michel Dänzer)
-- target-helpers: Do not build kms_dri on libdrm-less platforms. (Jon TURNEY)
-- r600g: gpu_shader5 gl_SampleMaskIn support (Glenn Kennard)
-- r600g: Implement gpu_shader5 integer ops (Glenn Kennard)
-- r600g: Add IMUL_HI/UMUL_HI support (Glenn Kennard)
-- r600g: Implement GL_ARB_texture_query_lod (Glenn Kennard)
-- gbm: Log at least one dlerror() when we fail to open any drivers. (Eric Anholt)
-- gbm: Fix a debug log message (Eric Anholt)
-- gallium: Add a uif() helper function to complement fui() (Eric Anholt)
-- glapi: Do not use backtrace on DragonFly. (Vinson Lee)
-- gallivm: fix up out-of-bounds level when using conformant out-of-bound behavior (Roland Scheidegger)
-- dri: Add a new capabilities for drivers that can't share buffers (Giovanni Campagna)
-- gallium: Add a dumb drm/kms winsys backed swrast provider (Giovanni Campagna)
-- Add support for swrast to the DRM EGL platform (Giovanni Campagna)
-- st/gbm: don't segfault if the fail to create the screen (Emil Velikov)
-- st/gbm: retrieve the driver-name via dd_driver_name() (Emil Velikov)
-- glsl/glcpp: rename ERROR to ERROR_TOKEN to fix MSVC build (Brian Paul)
-- configure: Don't override user -g or -O options for debug builds (Ian Romanick)
-- glsl: Add flex options to eliminate the default rule (Carl Worth)
-- glsl/glcpp: Add flex options to eliminate the default rule. (Carl Worth)
-- glsl/glcpp: Combine the two rules matching any character (Carl Worth)
-- glsl/glcpp: Alphabetize lists of start conditions (Carl Worth)
-- glsl/glcpp: Add a catch-all rule for unexpected characters. (Carl Worth)
-- glsl/glcpp: Treat carriage return as equivalent to line feed. (Carl Worth)
-- glsl/glcpp: Add test for a multi-line comment within an #if 0 block (Carl Worth)
-- glsl/glcpp: Test that macro parameters substitute immediately after periods (Carl Worth)
-- glsl/glcpp: Add (non)-support for ++ and -- operators (Carl Worth)
-- glsl/glcpp: Emit error for duplicate parameter name in function-like macro (Carl Worth)
-- glsl/glcpp: Add an explanatory comment for "loc != NULL" check (Carl Worth)
-- glsl/glcpp: Drop the HASH_ prefix from token names like HASH_IF (Carl Worth)
-- glsl: Properly lex extra tokens when handling # directives. (Kenneth Graunke)
-- glsl: Add an internal-error catch-all rule (Carl Worth)
-- glsl/glcpp: Correctly parse directives with intervening comments (Carl Worth)
-- glsl/glcpp: Rename HASH token to HASH_TOKEN (Carl Worth)
-- glsl/glcpp: Don't use start-condition stack when switching to/from <DEFINE> (Carl Worth)
-- glsl/glcpp: Add a -d/--debug option to the standalone glcpp program (Carl Worth)
-- glsl/glcpp: Fix off-by-one error in column in first-line error messages (Carl Worth)
-- glsl/glcpp: Minor tweak to wording of error message (Carl Worth)
-- glsl/glcpp: Stop using a lexer start condition (<SKIP>) for token skipping. (Carl Worth)
-- glsl/glcpp: Abstract a bit of common code for returning string tokens (Carl Worth)
-- glsl/glcpp: Drop extra, final newline from most output (Carl Worth)
-- glsl/glcpp: Add testing for EOF sans newline (and fix for <DEFINE>, <COMMENT>) (Carl Worth)
-- glsl/glcpp: Remove some un-needed calls to NEWLINE_CATCHUP (Carl Worth)
-- glsl/glcpp: Add support for comments between #define and macro identifier (Carl Worth)
-- glsl/glcpp: Emit proper error for #define with a non-identifier (Carl Worth)
-- glsl/glcpp: Add testing for directives preceded by a space (Carl Worth)
-- glsl/glcpp: Fix to emit spaces following directives (Carl Worth)
-- configure.ac: require libdrm_radeon 2.4.56 because of the Hawaii fix there (Marek Olšák)
-- main/get_hash_params: Add GL_SAMPLE_SHADING_ARB (Jason Ekstrand)
-- os_process.c: Add cygwin as an expected platform (Yaakov Selkowitz)
-- xmlconfig: Use program_invocation_short_name when building for cygwin (Yaakov Selkowitz)
-- docs: fix date typo: July 78 -> 18 (Brian Paul)
-- svga: remove unneeded depth==1 assertion in svga_texture_view_surface() (Brian Paul)
-- st/wgl: Clamp wglChoosePixelFormatARB's output nNumFormats to nMaxFormats. (José Fonseca)
-- gallium/radeon: Add some Emacs .dir-locals.el files (Michel Dänzer)
-- ilo: fix fb height of HiZ ops (Chia-I Wu)
-- glapi: add indexed blend functions (GL 4.0) (Tapani Pälli)
-- r600g,radeonsi: switch all occurences of array_size to util_max_layer (Marek Olšák)
-- radeonsi: fix occlusion queries on Hawaii (Marek Olšák)
-- winsys/radeon: fix vram_size overflow with Hawaii (Marek Olšák)
-- radeonsi: fix a hang with streamout on Hawaii (Marek Olšák)
-- radeonsi: fix a hang with instancing on Hawaii (Marek Olšák)
-- gallium/util: add a helper for calculating primitive count from vertex count (Marek Olšák)
-- radeonsi: fix CMASK and HTILE calculations for Hawaii (Marek Olšák)
-- r600g,radeonsi: add debug flags which disable tiling (Marek Olšák)
-- gallium: rename shader cap MAX_CONSTS to MAX_CONST_BUFFER_SIZE (Marek Olšák)
-- r600g: switch SNORM conversion to DX and GLES behavior (Marek Olšák)
-- util: Fix typo (Tom Stellard)
-- ilo: correctly propagate resource renames to hardware (Chia-I Wu)
-- ilo: add ilo_resource_get_bo() helper (Chia-I Wu)
-- radeonsi: Use util_memcpy_cpu_to_le32() (Tom Stellard)
-- util: Add util_memcpy_cpu_to_le32() v3 (Tom Stellard)
-- clover: Add checks for image support to the image functions v2 (Tom Stellard)
-- r600g/compute: Add debug information to promote and demote functions (Bruno Jiménez)
-- r600g/compute: Add documentation to compute_memory_pool (Bruno Jiménez)
-- ilo: unblock an inline write with a staging bo (Chia-I Wu)
-- ilo: try unblocking a transfer with a staging bo (Chia-I Wu)
-- ilo: enable persistent and coherent transfers (Chia-I Wu)
-- ilo: drop ptr from ilo_transfer (Chia-I Wu)
-- ilo: s/TRANSFER_MAP_UNSYNC/TRANSFER_MAP_GTT_UNSYNC/ (Chia-I Wu)
-- ilo: drop unused context param from transfer functions (Chia-I Wu)
-- ilo: tidy up transfer mapping/unmapping (Chia-I Wu)
-- ilo: tidy up choose_transfer_method() (Chia-I Wu)
-- ilo: free transfers with util_slab_free() (Chia-I Wu)
-- clover: Add clUnloadPlatformCompiler. (EdB)
-- clover: Add clCreateProgramWithBuiltInKernels. (EdB)
-- glsl/cs: Add several GLSL compute shader variables (Jordan Justen)
-- main/cs: Add additional compute shader constant values (Jordan Justen)
-- glsl: No longer require ubo block index to be constant in ir_validate (Chris Forbes)
-- glsl: Accept nonconstant array references in lower_ubo_reference (Chris Forbes)
-- glsl: Convert uniform_block in lower_ubo_reference to ir_rvalue. (Chris Forbes)
-- glsl: Mark entire UBO array active if indexed with non-constant. (Chris Forbes)
-- glsl: Allow non-constant UBO array indexing with GLSL4/ARB_gpu_shader5. (Chris Forbes)
-- ilo: simplify ilo_flush() (Chia-I Wu)
-- r600g/compute: Defrag the pool at the same time as we grow it (Bruno Jiménez)
-- r600g/compute: Try to use a temporary resource when growing the pool (Bruno Jiménez)
-- freedreno: fix typo in gpu version check (Rob Clark)
-- freedreno/ir3: split out shader compiler from a3xx (Rob Clark)
-- freedreno/a3xx/compiler: rename ir3_shader to ir3 (Rob Clark)
-- freedreno/a3xx/compiler: scheduler vs pred reg (Rob Clark)
-- freedreno/a3xx/compiler: little cleanups (Rob Clark)
-- freedreno/a3xx: enable/disable wa's based on patch-level (Rob Clark)
-- freedreno/a3xx/compiler: make IR heap dyanmic (Rob Clark)
-- r600g/compute: Fix singed/unsigned comparison compiler warnings. (Jan Vesely)
-- clover: Query the device to see if images are supported (Tom Stellard)
-- gallium: Add PIPE_CAP_COMPUTE_IMAGES_SUPPORTED (Tom Stellard)
-- r600g/compute: Allow compute_memory_defrag to defragment between resources (Bruno Jiménez)
-- r600g/compute: Allow compute_memory_move_item to move items between resources (Bruno Jiménez)
-- gbm: Search LIBGL_DRIVERS_PATH if GBM_DRIVERS_PATH is not set (Dylan Baker)
-- winsys/radeon: fix indentation (Jerome Glisse)
-- Add an accelerated version of F_TO_I for x86_64 (Jason Ekstrand)
-- i965/fs: Decide predicate/predicate_inverse outside of the for loop. (Matt Turner)
-- i965/fs: Swap if/else conditions in SEL peephole. (Matt Turner)
-- i965: Improve dead control flow elimination. (Matt Turner)
-- nvc0/ir: support 2d constbuf indexing (Ilia Mirkin)
-- gm107/ir: emit LDC subops (Ilia Mirkin)
-- gk110/ir: emit load constant subop (Ilia Mirkin)
-- mesa/st: add support for interpolate_at_* ops (Ilia Mirkin)
-- nv50/ir: fix phi/union sources when their def has been merged (Ilia Mirkin)
-- nv50/ir: fix hard-coded TYPE_U32 sized register (Ilia Mirkin)
-- nvc0: mark shader header if fp64 is used (Ilia Mirkin)
-- nv50/ir: keep track of whether the program uses fp64 (Ilia Mirkin)
-- nvc0: make sure that the local memory allocation is aligned to 0x10 (Ilia Mirkin)
-- mesa: add ARB_clear_texture.xml to file list, remove duplicate decls (Ilia Mirkin)
-- ilo: check the tilings of imported handles (Chia-I Wu)
-- ilo: clean up resource bo renaming (Chia-I Wu)
-- ilo: share some code between {tex,buf}_create_bo (Chia-I Wu)
-- ilo: use native 3-component vertex formats on GEN7.5+ (Chia-I Wu)
-- ilo: allow for device-dependent format translation (Chia-I Wu)
-- i965: Accelerate uploads of RGBA and BGRA GL_UNSIGNED_INT_8_8_8_8_REV textures (Jason Ekstrand)
-- mesa: Fix the name in the error message (Ian Romanick)
-- glsl: Fix some bad indentation (Ian Romanick)
-- i965/fs: Set LastRT on the final FB write on Broadwell. (Kenneth Graunke)
-- i965: Port INTEL_DEBUG=optimizer to the vec4 backend. (Kenneth Graunke)
-- i965: Save the gl_shader_stage enum in backend_visitor. (Kenneth Graunke)
-- i965: Don't print WE_normal in disassembly. (Kenneth Graunke)
-- freedreno/a3xx/compiler: fix p0 (kill, etc) (Rob Clark)
-- Revert "r600g/compute: Fix warnings" (Tom Stellard)
-- radeon/llvm: fix formatting (Grigori Goronzy)
-- radeon/llvm: enable unsafe math for graphics shaders (Grigori Goronzy)
-- r600g/compute: Fix warnings (Tom Stellard)
-- r600g: Use hardware sqrt instruction (Glenn Kennard)
-- r600g/compute: Remove unneeded code from compute_memory_promote_item (Bruno Jiménez)
-- r600g/compute: Quick exit if there's nothing to add to the pool (Bruno Jiménez)
-- r600g/compute: Defrag the pool if it's necesary (Bruno Jiménez)
-- r600g/compute: Add a function for defragmenting the pool (Bruno Jiménez)
-- r600g/compute: Add a function for moving items in the pool (Bruno Jiménez)
-- freedreno/a3xx: more vtx formats (Rob Clark)
-- freedreno/a3xx/compiler: const file relative addressing (Rob Clark)
-- freedreno/a3xx/compiler: move function (Rob Clark)
-- freedreno/a3xx: add back a few stalls (Rob Clark)
-- targets/dri: fix freedreno targets (Rob Clark)
-- freedreno: update generated headers (Rob Clark)
-- docs: Update GL3.txt and relnotes for GL_ARB_clear_texture (Neil Roberts)
-- meta: Add a meta implementation of GL_ARB_clear_texture (Neil Roberts)
-- meta: Add a state flag for the GL_DITHER (Neil Roberts)
-- texstore: Add a generic implementation of GL_ARB_clear_texture (Neil Roberts)
-- mesa/main: Add generic bits of ARB_clear_texture implementation (Neil Roberts)
-- teximage: Add utility func for format/internalFormat compatibility check (Neil Roberts)
-- mesa/main: add ARB_clear_texture entrypoints (Ilia Mirkin)
-- r600g/radeonsi: Use write-combined CPU mappings of some BOs in GTT (Michel Dänzer)
-- winsys/radeon: Use separate caching buffer managers for VRAM and GTT (Michel Dänzer)
-- docs/GL3.txt: update status for ARB_compute_shader (Dave Airlie)
-- mesa: Don't use memcpy() in _mesa_texstore() for float depth texture data (Anuj Phogat)
-- i965/fs: Fix gl_SampleMask handling for SIMD16 on Gen8+. (Kenneth Graunke)
-- i965/fs: Fix gl_SampleID for 2x MSAA and SIMD16 mode. (Kenneth Graunke)
-- i965: Add missing persample_shading field to brw_wm_debug_recompile. (Kenneth Graunke)
-- i965/disasm: Don't disassemble the URB complete field on Broadwell. (Kenneth Graunke)
-- i965: Disable hex offset printing in disassembly. (Kenneth Graunke)
-- i965/vec4: Use foreach_inst_in_block a couple more places. (Matt Turner)
-- i965: Replace cfg instances with calls to calculate_cfg(). (Matt Turner)
-- i965/cfg: Add a foreach_block_and_inst macro. (Matt Turner)
-- i965: Add cfg to backend_visitor. (Matt Turner)
-- radeonsi/compute: Add support scratch buffer support v2 (Tom Stellard)
-- radeonsi/compute: Bump number of user sgprs for LLVM 3.5 (Tom Stellard)
-- winsys/radeon: Query the kernel for the number of SEs and SHs per SE (Tom Stellard)
-- radeonsi/compute: Share COMPUTE_DBG macro with r600g (Tom Stellard)
-- radeonsi: Read rodata from ELF and append it to the end of shaders (Tom Stellard)
-- glsl: Fix bad indentation (Ian Romanick)
-- i965: Silence unused parameter warning (Ian Romanick)
-- i965: Silence 'comparison is always true' warning (Ian Romanick)
-- i965: Silence many unused parameter warnings (Ian Romanick)
-- configure.ac: Add LLVM patch version to error message. (Vinson Lee)
-- main/format_pack: Fix a wrong datatype in pack_ubyte_R8G8_UNORM (Jason Ekstrand)
-- docs: Import 10.2.4 release notes (Carl Worth)
-- Add support for RGBA8 and RGBX8 textures in intel_texsubimage_tiled_memcpy (Jason Ekstrand)
-- i965: Improve debug output in intelTexImage and intelTexSubimage (Jason Ekstrand)
-- radeonsi: only update vertex buffers when they need updating (Marek Olšák)
-- radeonsi: remove nr_vertex_buffers (Marek Olšák)
-- radeonsi: move vertex buffer descriptors from IB to memory (Marek Olšák)
-- radeonsi: add support for fine-grained sampler view updates (Marek Olšák)
-- radeonsi: move si_set_sampler_views to si_descriptors.c (Marek Olšák)
-- radeonsi: move sampler descriptors from IB to memory (Marek Olšák)
-- radeonsi: implement ARB_draw_indirect (Marek Olšák)
-- radeonsi: don't add info->start to the index buffer offset (Marek Olšák)
-- radeonsi: use an SGPR instead of VGT_INDX_OFFSET (Marek Olšák)
-- radeonsi: assume LLVM 3.4.2 is always present (Marek Olšák)
-- configure.ac: require LLVM 3.4.2 for radeon (Marek Olšák)
-- st/mesa,gallium: add a workaround for Unigine Heaven 4.0 and Valley 1.0 (Marek Olšák)
-- glsl: add a mechanism to allow #extension directives in the middle of shaders (Marek Olšák)
-- r600g: Implement GL_ARB_texture_gather (Glenn Kennard)
-- i965: Fix z_offset computation in intel_miptree_unmap_depthstencil() (Anuj Phogat)
-- Revert "i965: Extend compute-to-mrf pass to understand blocks of MOVs" (Anuj Phogat)
-- i915: Fix up intelInitScreen2 for DRI3 (Adel Gadllah)
-- mesa: Fix regression introduced by commit "mesa: fix packing of float texels to GL_SHORT/GL_BYTE". (Pavel Popov)
-- nv50: fix build failure on m68k due to invalid struct alignment assumptions (Thorsten Glaser)
-- clover: Call end_query before getting timestamp result v2 (Tom Stellard)
-- glsl: handle a switch where default is in the middle of cases (Tapani Pälli)
-- glsl: Make the tree rebalancer use vector_elements, not components(). (Kenneth Graunke)
-- glsl: Guard against error_type in the tree rebalancer. (Kenneth Graunke)
-- glsl: Make the tree rebalancer bail on matrix operands. (Kenneth Graunke)
-- Revert "i965: Implement GL_PRIMITIVES_GENERATED with non-zero streams." (Kenneth Graunke)
-- ilo: add some missing formats (Chia-I Wu)
-- ilo: update and tailor the surface format table (Chia-I Wu)
-- i965: Don't copy propagate abs into Broadwell logic instructions. (Kenneth Graunke)
-- i965/fs: Use WE_all for gl_SampleID header register munging. (Kenneth Graunke)
-- i965/fs: Set force_uncompressed and force_sechalf on samplepos setup. (Kenneth Graunke)
-- i965: Set execution size to 8 for instructions with force_sechalf set. (Kenneth Graunke)
-- nvc0: fix translate path for PRIM_RESTART_WITH_DRAW_ARRAYS (Christoph Bumiller)
-- nvc0: add support for indirect drawing (Christoph Bumiller)
-- nouveau: check if a fence has already been signalled (Ilia Mirkin)
-- glsl: Don't declare variables in for-loop declaration. (Matt Turner)
-- exec_list: Make various places use the new length() method. (Connor Abbott)
-- exec_list: Add a function to give the length of a list. (Connor Abbott)
-- exec_list: Add a prepend function. (Connor Abbott)
-- mesa: Don't allow GL_TEXTURE_{LUMINANCE,INTENSITY}_* queries outside compat profile (Ian Romanick)
-- mesa: Don't allow GL_TEXTURE_BORDER queries outside compat profile (Ian Romanick)
-- mesa: Handle uninitialized textures like other textures in get_tex_level_parameter_image (Ian Romanick)
-- i965/fs: Relax interference check in register coalescing. (Matt Turner)
-- i965/fs: Perform CSE on sends-from-GRF rather than textures. (Matt Turner)
-- glsl: Update expression types after rebalancing the tree. (Matt Turner)
-- glsl: Add callback_leave to ir_hierarchical_visitor. (Matt Turner)
-- i965: Initialize new chunks of realloc'd memory. (Matt Turner)
-- radeon/llvm: Fix LLVM diagnostic error reporting (Tom Stellard)
-- util/tgsi: Fix ureg_EMIT/ENDPRIM prototype. (José Fonseca)
-- glapi: Use GetProcAddress instead of dlsym on Windows. (Vinson Lee)
-- ilo: raise texture size limits (Chia-I Wu)
-- ilo: move away from drm_intel_bo_alloc_tiled (Chia-I Wu)
-- radeonsi: partially revert "switch descriptors to i32 vectors" (Marek Olšák)
-- i965/vec4: Invalidate live intervals in opt_cse, not _local. (Matt Turner)
-- i965/vec4: Move aeb list into opt_cse_local. (Matt Turner)
-- i965/fs: Invalidate live intervals in opt_cse, not _local. (Matt Turner)
-- i965/fs: Move aeb list into opt_cse_local. (Matt Turner)
-- glsl: Fix aggregates with dynamic initializers. (Cody Northrop)
-- Avoid mesa_dri_drivers import lib being installed (Jon TURNEY)
-- i965/vec4: Silence warnings about unhandled interpolation ops (Chris Forbes)
-- docs: Mark off ARB_gpu_shader5 interpolation functions for i965 (Chris Forbes)
-- i965/fs: add support for ir_*_interpolate_at_* expressions (Chris Forbes)
-- i965/fs: Skip channel expressions splitting for interpolation (Chris Forbes)
-- i965/fs: add generator support for pixel interpolator query (Chris Forbes)
-- i965: add low-level support for send to pixel interpolator (Chris Forbes)
-- i965/disasm: add support for pixel interpolator messages (Chris Forbes)
-- i965: Add message descriptor bit definitions for pixel interpolator (Chris Forbes)
-- i965/disasm: Disassemble indirect sends more properly (Chris Forbes)
-- i965: Avoid crashing while dumping vec4 insn operands (Chris Forbes)
-- i965: Fix two broken asserts in brw_eu_emit (Chris Forbes)
-- glsl: add new interpolateAt* builtin functions (Chris Forbes)
-- glsl: add new expression types for interpolateAt* (Chris Forbes)
-- allow builtin functions to require parameters to be shader inputs (Chris Forbes)
-- radeonsi: rename definitions of shader limits (Marek Olšák)
-- radeonsi: switch descriptors to i32 vectors (Marek Olšák)
-- radeonsi: properly implement texture opcodes that take an offset (Marek Olšák)
-- radeonsi: fix texture fetches with derivatives for 1DArray and 3D textures (Marek Olšák)
-- radeonsi: fix samplerCubeShadow with bias (Marek Olšák)
-- st/mesa: fix samplerCubeShadow with bias (Marek Olšák)
-- mesa: fix crash in st/mesa after deleting a VAO (Marek Olšák)
+- c40d7d6d948912a4d51cbf8f0854cf2ebe916636 commit
* Fri Jul 11 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.3-0.devel.1.f381c27c548aa28b003c8e188f5d627ab4105f76
- Rebase to 'master' branch (f381c27c548aa28b003c8e188f5d627ab4105f76 commit)