summaryrefslogtreecommitdiffstats
path: root/rubygem-pathspec.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-pathspec.spec')
-rw-r--r--rubygem-pathspec.spec45
1 files changed, 45 insertions, 0 deletions
diff --git a/rubygem-pathspec.spec b/rubygem-pathspec.spec
new file mode 100644
index 0000000..d4e4d33
--- /dev/null
+++ b/rubygem-pathspec.spec
@@ -0,0 +1,45 @@
+%global gem_name pathspec
+
+Name: rubygem-%{gem_name}
+Version: 0.0.2
+Release: 1%{?dist}
+Summary: Use to match path patterns such as gitignore
+
+License: ASL 2.0
+URL: https://rubygems.org/gems/%{gem_name}
+Source0: https://rubygems.org/downloads/%{gem_name}-%{version}.gem
+BuildArch: noarch
+
+BuildRequires: rubygems-devel
+
+%description
+Use to match path patterns such as gitignore.
+
+
+%prep
+gem unpack %{SOURCE0}
+%setup -q -D -T -n %{gem_name}-%{version}
+gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
+
+
+%build
+gem build %{gem_name}.gemspec
+%gem_install
+
+
+%install
+mkdir -p %{buildroot}%{gem_dir}
+cp -a ./%{gem_dir}/* %{buildroot}%{gem_dir}/
+
+
+%files
+%license LICENSE
+%{gem_cache}
+%{gem_docdir}
+%{gem_instdir}
+%{gem_spec}
+
+
+%changelog
+* Fri Apr 10 2015 Orion Poplawski <orion@cora.nwra.com> - 0.0.2-1
+- Initial package