summaryrefslogtreecommitdiffstats
path: root/rubygem-pathspec.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-pathspec.spec')
-rw-r--r--rubygem-pathspec.spec21
1 files changed, 20 insertions, 1 deletions
diff --git a/rubygem-pathspec.spec b/rubygem-pathspec.spec
index 5919a04..82ca5d4 100644
--- a/rubygem-pathspec.spec
+++ b/rubygem-pathspec.spec
@@ -8,9 +8,13 @@ Summary: Use to match path patterns such as gitignore
License: ASL 2.0
URL: https://rubygems.org/gems/%{gem_name}
Source0: https://rubygems.org/downloads/%{gem_name}-%{version}.gem
+Source1: rubygem-pathspec-generate-tarball.sh
+Source2: pathspec-ruby-%{version}-tests.tar.xz
BuildArch: noarch
BuildRequires: rubygems-devel
+BuildRequires: rubygem(rspec)
+BuildRequires: rubygem(fakefs)
%description
Use to match path patterns such as gitignore.
@@ -28,9 +32,18 @@ Documentation for %{name}.
%prep
gem unpack %{SOURCE0}
-%setup -q -D -T -n %{gem_name}-%{version}
+%setup -q -D -T -n %{gem_name}-%{version} -a 2
gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
+%if 0%{fedora} < 22
+ # Fedora 21 has Rspec 2.x, and Fedora 22 has Rspec 3.x.
+ # Switch to the older Rspec functions.
+ for f in $(find spec -type f); do
+ sed -i $f \
+ -e "s/is_expected\.to/should/g" \
+ -e "s/is_expected\.not_to/should_not/g"
+ done
+%endif
%build
gem build %{gem_name}.gemspec
@@ -41,6 +54,12 @@ gem build %{gem_name}.gemspec
mkdir -p %{buildroot}%{gem_dir}
cp -a ./%{gem_dir}/* %{buildroot}%{gem_dir}/
+%check
+cp -pr spec .%{gem_instdir}
+pushd .%{gem_instdir}
+ rspec -Ilib spec
+ rm -r spec/
+popd
%files
%license LICENSE