summaryrefslogtreecommitdiffstats
path: root/python-execnet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-execnet.spec')
-rw-r--r--python-execnet.spec17
1 files changed, 11 insertions, 6 deletions
diff --git a/python-execnet.spec b/python-execnet.spec
index 9839612..b5351ea 100644
--- a/python-execnet.spec
+++ b/python-execnet.spec
@@ -3,7 +3,7 @@
%global srcname execnet
Name: python-%{srcname}
-Version: 1.0.6
+Version: 1.0.7
Release: 1%{?rctag:.%rctag}%{?dist}
Summary: Elastic Python Deployment
Group: Development/Languages
@@ -36,6 +36,11 @@ enables interoperation between CPython 2.4-3.1, Jython 2.5 and PyPy
%prep
%setup -q -n %{srcname}-%{version}%{?rctag}
+# remove shebangs and fix permissions
+find . -type f -a \( -name '*.py' -o -name 'py.*' \) \
+ -exec sed -i '1{/^#!/d}' {} \; \
+ -exec chmod u=rw,go=r {} \;
+
%build
%{__python} setup.py build
@@ -46,11 +51,6 @@ make -C doc html
rm -rf %{buildroot}
%{__python} setup.py install -O1 --skip-build --root %{buildroot}
-# remove shebangs and fix permissions
-find %{buildroot}%{python_sitelib} \( -name '*.py' -o -name 'py.*' \) \
- -exec sed -i '1{/^#!/d}' {} \; \
- -exec chmod u=rw,go=r {} \;
-
# remove hidden file
rm doc/_build/html/.buildinfo
@@ -70,6 +70,11 @@ rm -rf %{buildroot}
%changelog
+* Sat Jul 10 2010 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.7-1
+- Update to 1.0.7.
+- Do cleanups already in %%prep to avoid inconsistent mtimes between
+ source files and bytecode.
+
* Sat May 8 2010 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.6-1
- Update to 1.0.6.