summaryrefslogtreecommitdiffstats
path: root/python-execnet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-execnet.spec')
-rw-r--r--python-execnet.spec49
1 files changed, 23 insertions, 26 deletions
diff --git a/python-execnet.spec b/python-execnet.spec
index 7a2fa1f..498c9bc 100644
--- a/python-execnet.spec
+++ b/python-execnet.spec
@@ -9,15 +9,13 @@
%global srcname execnet
Name: python-%{srcname}
-Version: 1.0.9
-Release: 3%{?dist}
+Version: 1.1
+Release: 1%{?dist}
Summary: Elastic Python Deployment
Group: Development/Languages
License: GPLv2+ and MIT
URL: http://codespeak.net/execnet
Source0: http://pypi.python.org/packages/source/e/%{srcname}/%{srcname}-%{version}.zip
-# upstream changeset 1a63deea3424
-Patch0: execnet-debugfilename.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: python-devel
@@ -36,16 +34,14 @@ Conflicts: python-py < 1.1.0
%description
-The execnet package allows to:
+execnet provides a share-nothing model with channel-send/receive
+communication for distributing execution across many Python
+interpreters across version, platform and network barriers. It has a
+minimal and fast API targetting the following uses:
- * instantiate local/remote Python Interpreters
- * send code for execution to one or many Interpreters
- * send and receive data between codeInterpreters through channels
-
-execnet performs zero-install bootstrapping into other interpreters;
-package installation is only required at the initiating side. execnet
-enables interoperation between CPython 2.4-3.1, Jython 2.5 and PyPy
-1.1 and works well on Windows, Linux and OSX systems.
+ * distribute tasks to (many) local or remote CPUs
+ * write and deploy hybrid multi-process applications
+ * write scripts to administer multiple environments
%if 0%{?with_python3}
@@ -56,22 +52,19 @@ Requires: python3-setuptools
%description -n python3-execnet
-The execnet package allows to:
-
- * instantiate local/remote Python Interpreters
- * send code for execution to one or many Interpreters
- * send and receive data between codeInterpreters through channels
-
-execnet performs zero-install bootstrapping into other interpreters;
-package installation is only required at the initiating side. execnet
-enables interoperation between CPython 2.4-3.1, Jython 2.5 and PyPy
-1.1 and works well on Windows, Linux and OSX systems.
+execnet provides a share-nothing model with channel-send/receive
+communication for distributing execution across many Python
+interpreters across version, platform and network barriers. It has a
+minimal and fast API targetting the following uses:
+
+ * distribute tasks to (many) local or remote CPUs
+ * write and deploy hybrid multi-process applications
+ * write scripts to administer multiple environments
%endif # with_python3
%prep
%setup -q -n %{srcname}-%{version}
-%patch0 -p1
# remove shebangs and fix permissions
find . -type f -a \( -name '*.py' -o -name 'py.*' \) \
@@ -112,8 +105,7 @@ rm doc/_build/html/.buildinfo
PYTHONPATH=$(pwd) py.test-%{python_version} -r s
%if 0%{?with_python3}
pushd %{py3dir}
-# see http://bugs.python.org/issue12591
-PYTHONPATH=$(pwd) py.test-%{python3_version} -r s -k-test_subprocess_interaction
+PYTHONPATH=$(pwd) py.test-%{python3_version} -r s
popd
%endif # with_python3
@@ -139,6 +131,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 22 2012 Thomas Moschny <thomas.moschny@gmx.de> - 1.1-1
+- Update to 1.1.
+- Update description.
+- Remove patch applied upstream.
+
* Tue Jan 17 2012 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.9-3
- Add upstream patch for failing test.