summaryrefslogtreecommitdiffstats
path: root/python-execnet.spec
diff options
context:
space:
mode:
authorThomas Moschny <thm@fedoraproject.org>2016-01-23 13:41:38 +0100
committerThomas Moschny <thm@fedoraproject.org>2016-01-23 13:41:38 +0100
commitf17796b6466ca1ea939b6eeaad41fba29cb43d7c (patch)
tree70c3d4060c4e087b7474fd7ca0c668b6385a019b /python-execnet.spec
parent0178361cc906debc348ee949e894ff25b7590ec1 (diff)
downloadpython-execnet-f17796b6466ca1ea939b6eeaad41fba29cb43d7c.tar.gz
python-execnet-f17796b6466ca1ea939b6eeaad41fba29cb43d7c.tar.xz
python-execnet-f17796b6466ca1ea939b6eeaad41fba29cb43d7c.zip
Update to 1.4.1.
- Apipkg has been debundled. - Follow updated Python packaging guidelines. - Spec file cleanups.
Diffstat (limited to 'python-execnet.spec')
-rw-r--r--python-execnet.spec101
1 files changed, 43 insertions, 58 deletions
diff --git a/python-execnet.spec b/python-execnet.spec
index 5131fd1..c8757a3 100644
--- a/python-execnet.spec
+++ b/python-execnet.spec
@@ -1,51 +1,33 @@
-%if 0%{?rhel} && 0%{?rhel} <= 6
-%{!?__python2: %global __python2 /usr/bin/python2}
-%{!?python2_sitelib: %global python2_sitelib %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
-%endif
-
-%if 0%{?fedora}
-%global with_python3 1
-%endif
-
%global srcname execnet
Name: python-%{srcname}
-Version: 1.3.0
-Release: 4%{?dist}
+Version: 1.4.1
+Release: 1%{?dist}
Summary: Elastic Python Deployment
-Group: Development/Languages
# package is now under the MIT license, (although the docs still say
# otherwise, see https://bitbucket.org/hpk42/execnet/issue/33), and
# one example file (doc/example/sysinfo.py) is GPLv2+
License: MIT and GPLv2+
URL: http://codespeak.net/execnet
Source0: http://pypi.python.org/packages/source/e/%{srcname}/%{srcname}-%{version}.tar.gz
-# pytest is too old in EL7 - this patch removes the failing @needssymlink decorator
-Patch2: python-execnet-needssymlink.patch
BuildArch: noarch
-BuildRequires: python-devel
-BuildRequires: python-setuptools
-Requires: python-setuptools
+BuildRequires: python2-devel
+BuildRequires: python2-setuptools
+BuildRequires: python-apipkg
BuildRequires: pytest
-BuildRequires: python-sphinx
-BuildRequires: /bin/ps
-BuildRequires: python-eventlet
BuildRequires: python-hgdistver
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 7
+BuildRequires: python-eventlet
BuildRequires: python-gevent >= 1.0
-%endif
-%if 0%{?with_python3}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
+BuildRequires: python3-apipkg
BuildRequires: python3-pytest
BuildRequires: python3-hgdistver
# these do not exist
#BuildRequires: python3-eventlet
#BuildRequires: python3-gevent
-%endif # with_python3
-# execnet was separated from pylib at that point
-Conflicts: python-py < 1.1.0
-
+BuildRequires: python-sphinx
+BuildRequires: /bin/ps
%description
execnet provides a share-nothing model with channel-send/receive
@@ -58,14 +40,30 @@ minimal and fast API targetting the following uses:
* write scripts to administer multiple environments
-%if 0%{?with_python3}
-%package -n python3-execnet
+%package -n python2-%{srcname}
Summary: Elastic Python Deployment
-Group: Development/Languages
-Requires: python3-setuptools
+%{?python_provide:%python_provide python2-%{srcname}}
+Requires: python2-setuptools
+Requires: python-apipkg
+
+%description -n python2-%{srcname}
+execnet provides a share-nothing model with channel-send/receive
+communication for distributing execution across many Python
+interpreters across version, platform and network barriers. It has a
+minimal and fast API targetting the following uses:
+
+ * distribute tasks to (many) local or remote CPUs
+ * write and deploy hybrid multi-process applications
+ * write scripts to administer multiple environments
-%description -n python3-execnet
+%package -n python3-%{srcname}
+Summary: Elastic Python Deployment
+%{?python_provide:%python_provide python3-%{srcname}}
+Requires: python3-setuptools
+Requires: python3-apipkg
+
+%description -n python3-%{srcname}
execnet provides a share-nothing model with channel-send/receive
communication for distributing execution across many Python
interpreters across version, platform and network barriers. It has a
@@ -74,14 +72,12 @@ minimal and fast API targetting the following uses:
* distribute tasks to (many) local or remote CPUs
* write and deploy hybrid multi-process applications
* write scripts to administer multiple environments
-%endif # with_python3
%prep
%setup -qc -n %{srcname}-%{version}
mv %{srcname}-%{version} python2
pushd python2
-%patch2 -p1
# remove shebangs and fix permissions
find . -type f -a \( -name '*.py' -o -name 'py.*' \) \
@@ -89,40 +85,33 @@ find . -type f -a \( -name '*.py' -o -name 'py.*' \) \
-exec chmod u=rw,go=r {} \;
popd
-%if 0%{?with_python3}
cp -a python2 python3
-%endif # with_python3
%build
pushd python2
-%{__python2} setup.py build
+%py2_build
make -C doc html
popd
-%if 0%{?with_python3}
pushd python3
-%{__python3} setup.py build
+%py3_build
make -C doc html
popd
-%endif # with_python3
%install
pushd python2
-%{__python2} setup.py install -O1 --skip-build --root %{buildroot}
+%py2_install
# remove hidden file
rm doc/_build/html/.buildinfo
popd
-%if 0%{?with_python3}
pushd python3
-%{__python3} setup.py install -O1 --skip-build --root %{buildroot}
+%py3_install
# remove hidden file
rm doc/_build/html/.buildinfo
popd
-%endif # with_python3
-
%check
@@ -130,41 +119,37 @@ pushd python2
PYTHONPATH=$(pwd) LC_ALL="en_US.UTF-8" \
py.test-%{python2_version} -r s -k'-test_stdouterrin_setnull' testing
popd
-%if 0%{?with_python3}
+
pushd python3
PYTHONPATH=$(pwd) LC_ALL="en_US.UTF-8" \
py.test-%{python3_version} -r s -k'-test_stdouterrin_setnull' testing
popd
-%endif # with_python3
-%files
+%files -n python2-%{srcname}
%{python2_sitelib}/%{srcname}*
%doc python2/README.txt
%doc python2/CHANGELOG
%doc python2/doc/_build/html
-%if 0%{?_licensedir:1}
%license python2/LICENSE
-%else
-%doc python2/LICENSE
-%endif # licensedir
-%if 0%{?with_python3}
-%files -n python3-execnet
+%files -n python3-%{srcname}
%{python3_sitelib}/%{srcname}*
%doc python3/README.txt
%doc python3/CHANGELOG
%doc python3/doc/_build/html
-%if 0%{?_licensedir:1}
%license python3/LICENSE
-%else
%doc python3/LICENSE
-%endif # licemsedir
-%endif # with_python3
%changelog
+* Sat Jan 23 2016 Thomas Moschny <thomas.moschny@gmx.de> - 1.4.1-1
+- Update to 1.4.1.
+- Apipkg has been debundled.
+- Follow updated Python packaging guidelines.
+- Spec file cleanups.
+
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-4
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5