summaryrefslogtreecommitdiffstats
path: root/SPECS
diff options
context:
space:
mode:
authorK. de Jong <kjong+dev@neobits.nl>2020-07-24 16:39:54 +0200
committerK. de Jong <kjong+dev@neobits.nl>2020-07-24 16:39:54 +0200
commit8ccaa26f529c614478d64b381a894ba2c53009a6 (patch)
tree59d6970274a5bb928daaa6de2659c7917ffe0fa4 /SPECS
parent2a01ff8d808926ffb6dc33e53865d84514fd4658 (diff)
downloadrpmbuild-8ccaa26f529c614478d64b381a894ba2c53009a6.tar.gz
rpmbuild-8ccaa26f529c614478d64b381a894ba2c53009a6.tar.xz
rpmbuild-8ccaa26f529c614478d64b381a894ba2c53009a6.zip
New spec/srpm files
Diffstat (limited to 'SPECS')
-rw-r--r--SPECS/dnf-plugin-rkhunter.spec17
-rw-r--r--SPECS/enroot.spec51
-rw-r--r--SPECS/pyxis.spec43
3 files changed, 105 insertions, 6 deletions
diff --git a/SPECS/dnf-plugin-rkhunter.spec b/SPECS/dnf-plugin-rkhunter.spec
index 376f6dc..b837d1e 100644
--- a/SPECS/dnf-plugin-rkhunter.spec
+++ b/SPECS/dnf-plugin-rkhunter.spec
@@ -1,7 +1,7 @@
%{!?dnf_lowest_compatible: %global dnf_lowest_compatible 4.2.23}
Name: dnf-plugin-rkhunter
-Version: 1.0
+Version: 1.1
Release: 1%{?dist}
Summary: Automatic updates of rkhunter property files after DNF transactions
@@ -14,7 +14,6 @@ BuildRequires: python3-devel
Requires: rkhunter
-%{?python_provide:%python_provide python3-%{name}}
Provides: python3-%{name} = %{version}-%{release}
%description
@@ -26,18 +25,24 @@ property files after each DNF transaction.
%install
mkdir -p %{buildroot}%{python3_sitelib}/dnf-plugins/
-mkdir -p %{buildroot}%_sysconfdir/dnf/plugins/
+mkdir -p %{buildroot}%{_sysconfdir}/dnf/plugins/
+mkdir -p %{buildroot}%{_defaultdocdir}/%{name}/
+mkdir -p %{buildroot}%{_defaultlicensedir}/%{name}/
mkdir -p %{buildroot}%{_mandir}/man8/
install -m 644 plugin/rkhunter.py %{buildroot}/%{python3_sitelib}/dnf-plugins/rkhunter.py
-install -m 644 etc/rkhunter.conf %{buildroot}%_sysconfdir/dnf/plugins/rkhunter.conf
+install -m 644 etc/rkhunter.conf %{buildroot}%{_sysconfdir}/dnf/plugins/rkhunter.conf
+install -m 644 README.md %{buildroot}%{_defaultdocdir}/%{name}/README.md
+install -m 644 LICENSE %{buildroot}%{_defaultlicensedir}/%{name}/LICENSE
install -m 644 man/dnf-plugin-rkhunter.8 %{buildroot}%{_mandir}/man8/%{name}.8
%files
%{python3_sitelib}/dnf-plugins/rkhunter.py
%{python3_sitelib}/dnf-plugins/__pycache__/rkhunter.*
-%_sysconfdir/dnf/plugins/rkhunter.conf
+%{_sysconfdir}/dnf/plugins/rkhunter.conf
+%{_defaultdocdir}/%{name}/README.md
+%{_defaultlicensedir}/%{name}/LICENSE
%{_mandir}/man8/%{name}.8*
%changelog
-* Wed Jul 22 2020 K. de Jong <keesdejong@fedoraproject.org> - 1.0-1
+* Wed Jul 22 2020 K. de Jong <keesdejong@fedoraproject.org> - 1.1-1
- Initial package
diff --git a/SPECS/enroot.spec b/SPECS/enroot.spec
new file mode 100644
index 0000000..babaaf7
--- /dev/null
+++ b/SPECS/enroot.spec
@@ -0,0 +1,51 @@
+Name: enroot
+Version: 3.1.0
+Release: 1%{?dist}
+License: ASL 2.0
+URL: https://github.com/NVIDIA/%{name}/
+Source0: https://github.com/NVIDIA/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+
+BuildRequires: git-core gcc make libcap libtool automake
+
+Summary: Unprivileged container sandboxing utility
+#Conflicts: enroot
+Requires: bash >= 4.2, curl, gawk, jq >= 1.5, parallel, shadow-utils, squashfs-tools
+Requires: coreutils, grep, findutils, gzip, glibc-common, sed, tar, util-linux, zstd
+#Recommends: pigz, ncurses
+#Suggests: libnvidia-container-tools, squashfuse, fuse-overlayfs
+%description
+A simple yet powerful tool to turn traditional container/OS images into
+unprivileged sandboxes.
+
+This package provides the main utility, its set of helper binaries and
+standard configuration files.
+
+%prep
+%setup -q
+
+%build
+%make_build prefix=%{_prefix} exec_prefix=%{_exec_prefix} libdir=%{_libdir} datarootdir=%{_datarootdir}
+
+%install
+%make_install prefix=%{_prefix} exec_prefix=%{_exec_prefix} libdir=%{_libdir} datarootdir=%{_datarootdir}
+
+%files
+%license LICENSE
+%config(noreplace) %{_sysconfdir}/*
+%{_libdir}/*
+%{_bindir}/*
+%{_datadir}/*
+
+%package -n %{name}+caps
+Summary: Unprivileged container sandboxing utility (extra capabilities)
+Requires: %{name}%{?_isa} = %{version}-%{release}, libcap
+%description -n %{name}+caps
+A simple yet powerful tool to turn traditional container/OS images into
+unprivileged sandboxes.
+
+This dependency package grants extra capabilities to unprivileged users which
+allows them to import and convert container images directly.
+
+%changelog
+* Tue Apr 28 2020 K. de Jong <keesdejong@fedoraproject.org> - 0.6.0-1
+- rebuilt
diff --git a/SPECS/pyxis.spec b/SPECS/pyxis.spec
new file mode 100644
index 0000000..c5f890f
--- /dev/null
+++ b/SPECS/pyxis.spec
@@ -0,0 +1,43 @@
+%global debug_package %{nil}
+
+Name: pyxis
+Version: 0.7.0
+Release: 1%{?dist}
+Summary: Pyxis is a SPANK plugin for the SLURM workload manager
+
+License: Apache License 2.0
+URL: https://github.com/NVIDIA/%{name}/
+Source0: https://github.com/NVIDIA/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
+
+BuildRequires: gcc
+BuildRequires: slurm-devel
+Requires: enroot >= 3.1.0
+
+%description
+Pyxis is a SPANK plugin for the SLURM Workload Manager. It allows unprivileged
+cluster users to run containerized tasks through the srun command.
+
+%prep
+%setup -q
+sed -i '/.*AUDIT_ARCH_AARCH64.*/d' seccomp_filter.h # seccomp_filter.h:28:38: error: 'AUDIT_ARCH_AARCH64' undeclared here (not in a function)
+
+%build
+make %{?_smp_mflags}
+
+%install
+make install prefix=%{_prefix} libdir=%{_libdir} DESTDIR=%{buildroot}
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md
+%{_libdir}/slurm/*
+%{_datadir}/%{name}/%{name}.conf
+
+%changelog
+* Wed Jul 15 2020 K. de Jong <keesdejong@fedoraproject.org> - 0.7.0-1
+- new version
+
+* Mon May 11 2020 K. de Jong <keesdejong@fedoraproject.org> - 0.6.0-1
+- Initial package
+