summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-02-19 05:39:55 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-02-19 05:39:55 +0000
commitfbceb40b901b71b0066c33ce96db8647cd3a31c8 (patch)
treeea1f16195c25d93a9fcefccbb65a798848e7f11a /configure.in
parent0f3158d547293938430fab74b4a78c8f91c11ddb (diff)
downloadruby-fbceb40b901b71b0066c33ce96db8647cd3a31c8.tar.gz
ruby-fbceb40b901b71b0066c33ce96db8647cd3a31c8.tar.xz
ruby-fbceb40b901b71b0066c33ce96db8647cd3a31c8.zip
* configure.in (darwin): uses -unexported_symbol option of ld instead
of objcopy git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@22435 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8934b493d..bdbffb06e 100644
--- a/configure.in
+++ b/configure.in
@@ -241,7 +241,7 @@ ASFLAGS=$ASFLAGS
AC_SUBST(ASFLAGS)
case "$target_os" in
-when(cygwin*|mingw*)
+when(cygwin*|mingw*|darwin*)
ac_cv_prog_ac_ct_OBJCOPY=":";;
esac
@@ -1833,7 +1833,10 @@ if test "$enable_shared" = 'yes'; then
when(darwin*)
RUBY_SO_NAME="$RUBY_SO_NAME"'.$(MAJOR).$(MINOR).$(TEENY)'
LIBRUBY_LDSHARED='cc -dynamiclib -undefined suppress -flat_namespace'
- LIBRUBY_DLDFLAGS='-install_name $(libdir)/lib$(RUBY_SO_NAME).dylib -current_version $(MAJOR).$(MINOR).$(TEENY) -compatibility_version $(MAJOR).$(MINOR).$(TEENY)'
+ LIBRUBY_DLDFLAGS='-install_name $(libdir)/lib$(RUBY_SO_NAME).dylib'
+ LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-current_version $(MAJOR).$(MINOR).$(TEENY)'
+ LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-compatibility_version $(MAJOR).$(MINOR).$(TEENY)'
+ LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-Wl,-unexported_symbol,_Init_* $(XLDFLAGS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).dylib.$(MAJOR).$(MINOR).$(TEENY)'
LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).dylib lib$(RUBY_INSTALL_NAME).$(MAJOR).$(MINOR).dylib lib$(RUBY_INSTALL_NAME).dylib'
;;