summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-01-23 06:41:22 +0000
committerusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-01-23 06:41:22 +0000
commite633201bad09dfc9bd34c0dd5aa7fdb9fcb80178 (patch)
tree67ab16e42050bfcabecbbfa8be63132bbf2038c8 /configure.in
parent6cedeef9dc39fdbde93367c57adbb69a6630b5db (diff)
downloadruby-e633201bad09dfc9bd34c0dd5aa7fdb9fcb80178.tar.gz
ruby-e633201bad09dfc9bd34c0dd5aa7fdb9fcb80178.tar.xz
ruby-e633201bad09dfc9bd34c0dd5aa7fdb9fcb80178.zip
* Makefile.in, common.mk, configure.in, */{Makefile.sub, configure.bat,
setup.mak}: add --with-baseruby configure option. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@11559 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be6bbd212..1343697b5 100644
--- a/configure.in
+++ b/configure.in
@@ -1606,6 +1606,23 @@ if test -z "$MANTYPE"; then
fi
AC_SUBST(MANTYPE)
+AC_ARG_WITH(baseruby,
+ [ --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby],
+ [
+ case "$withval" in
+ *ruby*)
+ BASERUBY=$withval
+ ;;
+ *)
+ AC_MSG_ERROR(need ruby)
+ ;;
+ esac
+ ],
+ [
+ BASERUBY="ruby"
+ ])
+AC_SUBST(BASERUBY)
+
if test -f config.h && tr -d '\015' < confdefs.h | cmp -s config.h -; then
echo "config.h unchanged"
else