summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-24 17:16:40 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-24 17:16:40 +0000
commitd70d4b00d89d6616493e0c9a4926172b3978611a (patch)
tree0363f2386aadad59fe341cd054f626a76305f070 /configure.in
parent72433ac9026a4ea198fda4603f293e32506c431e (diff)
downloadruby-d70d4b00d89d6616493e0c9a4926172b3978611a.tar.gz
ruby-d70d4b00d89d6616493e0c9a4926172b3978611a.tar.xz
ruby-d70d4b00d89d6616493e0c9a4926172b3978611a.zip
* configure.in (DLDFLAGS): use linker_flag and changed undefined
and multiply_defined behaviors. cf [ruby-core:25086]. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@24642 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 41fee2a01..69f292b16 100644
--- a/configure.in
+++ b/configure.in
@@ -1723,7 +1723,8 @@ if test "$with_dln_a_out" != yes; then
when(rhapsody*) : ${LDSHARED='cc -dynamic -bundle -undefined suppress'}
: ${LDFLAGS=""}
rb_cv_dlopen=yes ;;
- when(darwin*) : ${LDSHARED='$(CC) -dynamic -bundle -undefined suppress -flat_namespace'}
+ when(darwin*) : ${LDSHARED='$(CC) -dynamic -bundle'}
+ : ${DLDFLAGS="${linker_flag}-undefined${linker_flag:+,}dynamic_lookup ${linker_flag}-multiply_defined${linker_flag:+,}suppress ${linker_flag}-flat_namespace"}
: ${LDFLAGS=""}
: ${LIBPATHENV=DYLD_LIBRARY_PATH}
# /usr/local/include is always searched for
@@ -2049,13 +2050,13 @@ if test "$enable_shared" = 'yes'; then
;;
when(darwin*)
RUBY_SO_NAME="$RUBY_SO_NAME"'.$(MAJOR).$(MINOR).$(TEENY)'
- LIBRUBY_LDSHARED='$(CC) -dynamiclib -undefined suppress -flat_namespace'
+ LIBRUBY_LDSHARED='$(CC) -dynamiclib'
if test "$load_relative" = yes; then
libprefix='@executable_path/../lib'
else
libprefix='$(libdir)'
fi
- LIBRUBY_DLDFLAGS='-install_name '${libprefix}'/$(LIBRUBY_SO)'
+ LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-install_name '${libprefix}'/$(LIBRUBY_SO)'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-current_version $(MAJOR).$(MINOR).$(TEENY)'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-compatibility_version $(ruby_version)'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-Wl,-unexported_symbol,_Init_* $(XLDFLAGS)'