summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorakr <akr@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-07 04:55:48 +0000
committerakr <akr@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-07 04:55:48 +0000
commitd21ec328e858659d475acefc1714b5b91dfaad39 (patch)
tree5ca37556eea1466851bbc9380a6281e33f220a05 /configure.in
parente04b95c0d59a297fd0619f22f10848e08d762798 (diff)
downloadruby-d21ec328e858659d475acefc1714b5b91dfaad39.tar.gz
ruby-d21ec328e858659d475acefc1714b5b91dfaad39.tar.xz
ruby-d21ec328e858659d475acefc1714b5b91dfaad39.zip
* configure.in: the shell which runs configure may be different from
the shell for make. configure likes bash but Makefile specifies SHELL=/bin/sh. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@22807 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 569deefb5..0fad3c0b0 100644
--- a/configure.in
+++ b/configure.in
@@ -302,7 +302,7 @@ mkdir conf$$.dir &&
(cd conf$$.dir && mkdir src build && cd src &&
$as_ln_s ../build . > /dev/null 2>&1 && cd build &&
for chdir in 'cd -P' 'PWD= cd'; do
- ($chdir ../src 2> /dev/null && echo "$chdir" > cdcmd) && break
+ ( ${CONFIG_SHELL-/bin/sh} -c "$chdir ../src" 2> /dev/null && echo "$chdir" > cdcmd) && break
done)
if test -e conf$$.dir/src/cdcmd; then
read CHDIR < conf$$.dir/src/cdcmd 2> /dev/null