summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-12-12 01:28:10 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-12-12 01:28:10 +0000
commitad3f23b466755a880d4052c1617bf935b6cca6e7 (patch)
treea5941b0dfa76977a2da550dbd0ecb90ddf1d7fec /configure.in
parent42826ccf1d58b337ad9c0c5fdc45eea29e07c8f3 (diff)
downloadruby-ad3f23b466755a880d4052c1617bf935b6cca6e7.tar.gz
ruby-ad3f23b466755a880d4052c1617bf935b6cca6e7.tar.xz
ruby-ad3f23b466755a880d4052c1617bf935b6cca6e7.zip
* configure.in (rb_version): greps only the line that defines version.
* version.h (RUBY_VERSION_CODE, RUBY_RELEASE_CODE): removed. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@20654 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 34fe037d2..62c55774a 100644
--- a/configure.in
+++ b/configure.in
@@ -64,7 +64,7 @@ GNU_LD=$rb_cv_prog_gnu_ld
AC_SUBST(GNU_LD)])
unset GREP_OPTIONS
-rb_version=`grep RUBY_VERSION $srcdir/version.h`
+rb_version=`grep '^#define RUBY_VERSION ' $srcdir/version.h`
MAJOR=`expr "$rb_version" : '#define RUBY_VERSION "\([0-9][0-9]*\)\.[0-9][0-9]*\.[0-9][0-9]*"'`
MINOR=`expr "$rb_version" : '#define RUBY_VERSION "[0-9][0-9]*\.\([0-9][0-9]*\)\.[0-9][0-9]*"'`
TEENY=`expr "$rb_version" : '#define RUBY_VERSION "[0-9][0-9]*\.[0-9][0-9]*\.\([0-9][0-9]*\)"'`