summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-02-10 21:41:26 +0000
committerknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-02-10 21:41:26 +0000
commita9cb5734bb8d3697e454bce3426763c7afeee80f (patch)
tree850a447972a24dbc0fb468f5466342a26a93d486 /configure.in
parent36d512afb399c4cda2a891f7ace35916e418481f (diff)
downloadruby-a9cb5734bb8d3697e454bce3426763c7afeee80f.tar.gz
ruby-a9cb5734bb8d3697e454bce3426763c7afeee80f.tar.xz
ruby-a9cb5734bb8d3697e454bce3426763c7afeee80f.zip
* configure.in, ext/thread/extconf.rb, lib/thread.rb: Add a
configure option `--disable-fastthread', to choose the original, pure ruby version of the "thread" library instead of the new, much faster implementation in ext/thread. git-svn-id: http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_8@11698 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ea087c26f..4c59fa488 100644
--- a/configure.in
+++ b/configure.in
@@ -350,6 +350,11 @@ AC_ARG_ENABLE(pthread,
[ --enable-pthread use pthread library.],
[enable_pthread=$enableval], [enable_pthread=no])
+AC_ARG_ENABLE(fastthread,
+ [ --disable-fastthread do not use the fastthread mutex], [
+ : handled by ext/thread/extconf.rb
+ ])
+
dnl Checks for libraries.
case "$target_os" in
nextstep*) ;;