summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-16 08:33:02 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-16 08:33:02 +0000
commit9ea86fe3bb33bfa402f0336c93f6a09cd3e00eb6 (patch)
treec53d83f0d0e87ea591a3f7385965d15b26ed7410 /configure.in
parente716038dada847e30a2433e958a954f42ff84d83 (diff)
downloadruby-9ea86fe3bb33bfa402f0336c93f6a09cd3e00eb6.tar.gz
ruby-9ea86fe3bb33bfa402f0336c93f6a09cd3e00eb6.tar.xz
ruby-9ea86fe3bb33bfa402f0336c93f6a09cd3e00eb6.zip
* configure.in (Makefile): set VCS and VCSUP.
* Makefile.in, win32/Makefile.sub (up): split from common.mk. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@21602 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 60662e2c5..a2ea066d2 100644
--- a/configure.in
+++ b/configure.in
@@ -2159,7 +2159,20 @@ AC_SUBST(PACKAGE)
AC_CONFIG_FILES(Doxyfile)
AC_CONFIG_FILES($FIRSTMAKEFILE)
AC_CONFIG_FILES(Makefile, [{
- sed '/^MISSING/s/\$U\././g' Makefile
+ if test -d "$srcdir/.svn"; then
+ VCS='svn'
+ VCSUP='$(VCS) up $(SVNUPOPTIONS)'
+ elif test -d "$srcdir/.git/svn"; then
+ VCS='git svn'
+ VCSUP='$(VCS) up $(SVNUPOPTIONS)'
+ elif test -d "$srcdir/.git"; then
+ VCS='git'
+ VCSUP='$(VCS) up $(GITUPOPTIONS)'
+ else
+ VCS='echo cannot'
+ VCSUP='$(VCS)'
+ fi
+ sed '/^MISSING/s/\$U\././g;/^VCS *=/s#@VCS@#'"$VCS"'#;/^VCSUP *=/s#@VCSUP@#'"$VCSUP"'#' Makefile
echo; test x"$EXEEXT" = x || echo 'miniruby: miniruby$(EXEEXT)'
test "$RUBY_INSTALL_NAME$EXEEXT" = ruby || echo 'ruby: $(PROGRAM);'
if test "$gnumake" != yes; then