summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-26 02:05:54 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-26 02:05:54 +0000
commit9785c5a969bcf1514a7b20b43987be88d8c81d84 (patch)
tree13d6ff2bc71527cbc3dd8570d8764ed1d2643efb /configure.in
parent2dda653fb39b6b9a9301f7951e13eaa9419893ca (diff)
downloadruby-9785c5a969bcf1514a7b20b43987be88d8c81d84.tar.gz
ruby-9785c5a969bcf1514a7b20b43987be88d8c81d84.tar.xz
ruby-9785c5a969bcf1514a7b20b43987be88d8c81d84.zip
* configure.in (aix): -b must come at the start of the command line,
and -e must not appear while testing libraries. [ruby-talk:104501] git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@6523 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0358f1d7e..f402c3f61 100644
--- a/configure.in
+++ b/configure.in
@@ -913,9 +913,12 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes ;;
aix*) : ${LDSHARED='/usr/ccs/bin/ld'}
XLDFLAGS="$XLDFLAGS -Wl,-bE:ruby.imp"
- DLDFLAGS="$DLDFLAGS "'-brtl -eInit_$(TARGET) -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 -lc'
- : LDFLAGS="$LDFLAGS -brtl"
+ DLDFLAGS='-brtl -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 '"$DLDFLAGS"
+ ARCH_FLAGS='-eInit_$(TARGET)'
+ : LDFLAGS="-brtl $LDFLAGS"
: ${ARCHFILE="ruby.imp"}
+ TRY_LINK='$(CC) $(DLDFLAGS) -oconftest $(INCFLAGS) -I$(hdrdir) $(CPPFLAGS) $(CFLAGS)'
+ TRY_LINK="$TRY_LINK"' $(src) $(LIBPATH) $(LOCAL_LIBS) $(LIBS)'
: ${LIBPATHENV=SHLIB_PATH}
rb_cv_dlopen=yes ;;