summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-05-01 09:42:38 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-05-01 09:42:38 +0000
commit817a62de81d75c73cceb453301ef27b094f17c14 (patch)
tree65e06d76c544a8d80296d686bf88ec3af41fdc50 /configure.in
parent5cffff58445b5aec50bd4abe2198bf84b8dd68c4 (diff)
downloadruby-817a62de81d75c73cceb453301ef27b094f17c14.tar.gz
ruby-817a62de81d75c73cceb453301ef27b094f17c14.tar.xz
ruby-817a62de81d75c73cceb453301ef27b094f17c14.zip
2000-05-01
git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@678 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6fd4117c2..83cb5783a 100644
--- a/configure.in
+++ b/configure.in
@@ -44,6 +44,12 @@ AC_ARG_ENABLE(fat-binary,
TARGET_ARCHS="ppc i386"
fi
;;
+ macos*)
+ echo -n "MacOS X : "
+ if test "$TARGET_ARCHS" = "" ; then
+ TARGET_ARCHS="ppc i386"
+ fi
+ ;;
nextstep*|openstep*)
echo -n "NeXTSTEP/OPENSTEP: "
if test "$TARGET_ARCHS" = "" ; then
@@ -155,6 +161,7 @@ case "$target_os" in
nextstep*) ;;
openstep*) ;;
rhapsody*) ;;
+macos*) ;;
human*) ac_cv_func_getpgrp_void=yes;;
beos*) ;;
cygwin*) ;;
@@ -407,6 +414,7 @@ if test "$with_dln_a_out" != yes; then
nextstep*) ;;
openstep*) ;;
rhapsody*) ;;
+ macos*) ;;
human*) ;;
bsdi*) ;;
cygwin*) ;;
@@ -485,6 +493,10 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS=""
DLDFLAGS="$ARCH_FLAG"
rb_cv_dlopen=yes ;;
+ macos*) LDSHARED='cc -dynamic -bundle -undefined suppress'
+ LDFLAGS=""
+ DLDFLAGS="$ARCH_FLAG"
+ rb_cv_dlopen=yes ;;
aix*) LDSHARED='/usr/ccs/bin/ld'
XLDFLAGS='-Wl,-bE:ruby.imp'
DLDFLAGS='-eInit_$(TARGET) -bI:$(topdir)/ruby.imp -bM:SRE -T512 -H512 -lc'
@@ -553,8 +565,8 @@ else
AC_DEFINE(DLEXT, ".bundle");;
rhapsody*) DLEXT=bundle
AC_DEFINE(DLEXT, ".bundle");;
- cygwin*) DLEXT=dll
- AC_DEFINE(DLEXT, ".dll");;
+ macos*) DLEXT=bundle
+ AC_DEFINE(DLEXT, ".bundle");;
os2_emx*) DLEXT=dll
AC_DEFINE(DLEXT, ".dll");;
*) DLEXT=so
@@ -578,6 +590,8 @@ case "$target_os" in
STRIP='strip -A -n';;
rhapsody*)
STRIP='strip -A -n';;
+ macos*)
+ STRIP='strip -A -n';;
esac
EXTSTATIC=