summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-16 00:03:31 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-16 00:03:31 +0000
commit6cd533926f8cfa75029b2a78f78fc54049e9c642 (patch)
tree5c86fe13784092d3af0f07a5869a640f8fedc124 /configure.in
parent0450e78be5db05286a4f29eb2fd5661159188f98 (diff)
downloadruby-6cd533926f8cfa75029b2a78f78fc54049e9c642.tar.gz
ruby-6cd533926f8cfa75029b2a78f78fc54049e9c642.tar.xz
ruby-6cd533926f8cfa75029b2a78f78fc54049e9c642.zip
* configure.in (ruby_version): now version.h includes
include/ruby/version.h, so need to tell to cpp to see $(srcdir)/include. [ruby-core:23468] git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@23434 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b63c67717..3680a2d10 100644
--- a/configure.in
+++ b/configure.in
@@ -2317,7 +2317,7 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
echo '#include "version.h"'
echo 'ruby_version=RUBY_LIB_VERSION'
} > conftest.c
- ruby_version="`$CPP -I"${srcdir}" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
+ ruby_version="`$CPP -I"${srcdir}" -I"${srcdir}/include" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
eval $ruby_version
else
RUBY_LIB_VERSION="\"${ruby_version}\""