summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-09-11 05:22:46 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-09-11 05:22:46 +0000
commit6b9eeba4ecf022cc9e8dc6c0e74838427075ef27 (patch)
tree5a8301c2058c21cb722c0e3047828f32e7cd0b34 /configure.in
parentad9f1469c2bdaa7bab3c8ded3a077f3f2c02a788 (diff)
downloadruby-6b9eeba4ecf022cc9e8dc6c0e74838427075ef27.tar.gz
ruby-6b9eeba4ecf022cc9e8dc6c0e74838427075ef27.tar.xz
ruby-6b9eeba4ecf022cc9e8dc6c0e74838427075ef27.zip
* configure.in (debugflags): use gdb by default on linux and
darwin. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@24847 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a858fedc8..973256a14 100644
--- a/configure.in
+++ b/configure.in
@@ -239,13 +239,17 @@ fi
AC_PROG_CC
AC_PROG_CXX
AC_PROG_GCC_TRADITIONAL
-test $ac_cv_prog_cc_g = yes && : ${debugflags=-g}
if test "$GCC" = yes; then
linker_flag=-Wl,
: ${optflags=-O3}
+ case "$target_os" in
+ when(linux*|darwin*)
+ : ${debugflags=-ggdb};;
+ esac
else
linker_flag=
fi
+test $ac_cv_prog_cc_g = yes && : ${debugflags=-g}
RUBY_PROG_GNU_LD
RUBY_CPPOUTFILE