summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-25 14:33:11 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-25 14:33:11 +0000
commit62d085ce7a4e38b0bfc08e840c9e8fff27eb429b (patch)
treea4226461404da7421ce1a5cf7d31d1e649a75381 /configure.in
parentbea254507b214740ae886d8a7123a4d665af5fa3 (diff)
downloadruby-62d085ce7a4e38b0bfc08e840c9e8fff27eb429b.tar.gz
ruby-62d085ce7a4e38b0bfc08e840c9e8fff27eb429b.tar.xz
ruby-62d085ce7a4e38b0bfc08e840c9e8fff27eb429b.zip
Fix for Linux compatibility
git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@24650 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 86692b862..bc0a2c0e2 100644
--- a/configure.in
+++ b/configure.in
@@ -309,12 +309,13 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_INSTALL
AC_PROG_MKDIR_P
-if test "x$MKDIR_P" != "x -d"; then
-elif test x"$as_mkdir_p" != xfalse; then
- MKDIR_P='mkdir -p'
- echo "use 'mkdir -p' as MKDIR_P"
-else
- AC_MSG_ERROR([mkdir -p is required])
+if test "x$MKDIR_P" = "x -d"; then
+ if test x"$as_mkdir_p" != xfalse; then
+ MKDIR_P='mkdir -p'
+ echo "use 'mkdir -p' as MKDIR_P"
+ else
+ AC_MSG_ERROR([mkdir -p is required])
+ fi
fi
MAKEDIRS="$MKDIR_P"
AC_SUBST(MAKEDIRS)