summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-24 04:14:12 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-24 04:14:12 +0000
commit4dda89491c43ee9f52982691403a60bdbb28e414 (patch)
tree78d0c70524d22b6ebd614ee2d845e76cb19dea17 /configure.in
parent0e2ef1a71d0d340c8df0a72e94e42caac5c0166c (diff)
downloadruby-4dda89491c43ee9f52982691403a60bdbb28e414.tar.gz
ruby-4dda89491c43ee9f52982691403a60bdbb28e414.tar.xz
ruby-4dda89491c43ee9f52982691403a60bdbb28e414.zip
* configure.in (RUBY_CHECK_SIZEOF): set cross_compiling only when
universal binary. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@24634 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 005a2e30b..41fee2a01 100644
--- a/configure.in
+++ b/configure.in
@@ -385,10 +385,10 @@ esac
AC_CHECK_TYPES([long long, off_t])
AC_CACHE_CHECK([char bit], [rb_cv_char_bit],
- [cross_compiling=yes
+ [test "$universal_binary" = yes && cross_compiling=yes
AC_COMPUTE_INT([rb_cv_char_bit], [CHAR_BIT],
[AC_INCLUDES_DEFAULT([@%:@include <limits.h>])], [rb_cv_char_bit=8])
- cross_compiling=$real_cross_compiling])
+ test "$universal_binary" = yes && cross_compiling=$real_cross_compiling])
dnl RUBY_CHECK_SIZEOF [typename], [maybe same size types], [macros], [include]
AC_DEFUN([RUBY_CHECK_SIZEOF],
@@ -433,7 +433,7 @@ static ac__type_sizeof_ *rbcv_ptr;
m4_ifval([$2][$3], [case "${AS_TR_SH(ac_cv_sizeof_$1)}" in
when([SIZEOF_*]);;
when(*)])
- cross_compiling=yes
+ test "$universal_binary" = yes && cross_compiling=yes
AC_COMPUTE_INT([t], AS_TR_CPP(SIZEOF_$1), [AC_INCLUDES_DEFAULT([$4])]
[${cond+$cond
@%:@else}
@@ -442,7 +442,7 @@ ${cond+@%:@endif}
@%:@ifndef AS_TR_CPP(SIZEOF_$1)
@%:@define AS_TR_CPP(SIZEOF_$1) 0
@%:@endif], [t=0])
- cross_compiling=$real_cross_compiling
+ test "$universal_binary" = yes && cross_compiling=$real_cross_compiling
if test ${t-0} != 0; then
AS_TR_SH(ac_cv_sizeof_$1)="${AS_TR_SH(ac_cv_sizeof_$1)+${AS_TR_SH(ac_cv_sizeof_$1)-} }${t}"
fi