summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-27 22:39:24 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-27 22:39:24 +0000
commit4cba98c49141dd6ce2ed4fd5d873188939101790 (patch)
treeec6ae9e4a5fb471b1f09f455b889d72e4a82b611 /configure.in
parent7e1424bfa804448f39a9ffcdccace1cce0e948a2 (diff)
downloadruby-4cba98c49141dd6ce2ed4fd5d873188939101790.tar.gz
ruby-4cba98c49141dd6ce2ed4fd5d873188939101790.tar.xz
ruby-4cba98c49141dd6ce2ed4fd5d873188939101790.zip
* configure.in (THREAD_MODEL): reject unknown value and checks
pthread.h only when pthread. [ruby-core:23577] git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@23601 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f03dbfe30..60efa337c 100644
--- a/configure.in
+++ b/configure.in
@@ -930,7 +930,7 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(limits.h sys/file.h sys/ioctl.h sys/syscall.h\
fcntl.h sys/fcntl.h sys/select.h sys/time.h sys/times.h sys/param.h\
syscall.h pwd.h grp.h a.out.h utime.h direct.h sys/resource.h \
- sys/mkdev.h sys/utime.h xti.h netinet/in_systm.h float.h ieeefp.h pthread.h \
+ sys/mkdev.h sys/utime.h xti.h netinet/in_systm.h float.h ieeefp.h \
ucontext.h intrinsics.h langinfo.h locale.h sys/sendfile.h time.h \
net/socket.h sys/socket.h)
@@ -2167,6 +2167,17 @@ case "$target_os" in
esac
MINIOBJS="$MINIDLNOBJ"
+case "$THREAD_MODEL" in
+when(pthread)
+ AC_CHECK_HEADERS(pthread.h)
+ ;;
+when(win32)
+ ;;
+when(*)
+ AC_MSG_ERROR(unknown thread model $THREAD_MODEL)
+ ;;
+esac
+
case "$FIRSTMAKEFILE" in
when(*GNUmakefile:*)
gnumake=yes