summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-07-20 02:13:00 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-07-20 02:13:00 +0000
commit2cafc2926fa745dcac33cc3a2af94df4db74c1c5 (patch)
tree4f4aa8517faf83ce673555faa15b74d6332eff59 /configure.in
parent5f84a40b6c39e1aa02de21a1a9e64dc8e166ea52 (diff)
downloadruby-2cafc2926fa745dcac33cc3a2af94df4db74c1c5.tar.gz
ruby-2cafc2926fa745dcac33cc3a2af94df4db74c1c5.tar.xz
ruby-2cafc2926fa745dcac33cc3a2af94df4db74c1c5.zip
* configure.in, Makefile.in (TEST_RUNNABLE): tests are not
runnable if cross-compiling. * common.mk (btest*, test*): ditto. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@24209 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8779e983a..a2a7c594e 100644
--- a/configure.in
+++ b/configure.in
@@ -1910,12 +1910,15 @@ if test x"$cross_compiling" = xyes; then
test x"$MINIRUBY" = x && MINIRUBY="${RUBY-ruby} -I`pwd` "-r'$(arch)-fake'
PREP='$(arch)-fake.rb'
RUNRUBY='$(MINIRUBY) -I`cd $(srcdir)/lib; pwd`'
+ TEST_RUNNABLE=no
else
MINIRUBY='./miniruby$(EXEEXT) -I$(srcdir)/lib'
MINIRUBY="$MINIRUBY"' -I$(EXTOUT)/common -I./- -r$(srcdir)/ext/purelib.rb'
PREP='miniruby$(EXEEXT)'
RUNRUBY='$(MINIRUBY) $(srcdir)/tool/runruby.rb --extout=$(EXTOUT)'
+ TEST_RUNNABLE=yes
fi
+AC_SUBST(TEST_RUNNABLE)
AC_SUBST(MINIRUBY)
AC_SUBST(PREP)
AC_SUBST(RUNRUBY)