summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-11-14 06:18:59 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-11-14 06:18:59 +0000
commit20f5f4816288b7344bcfaca128f32dc14a60c51a (patch)
tree258fdf9c591ffa5bab8d8be49302198241eb4fa7 /configure.in
parentbbb3768f02a7b40d3a3d0611a7d1d5a27eceaca8 (diff)
downloadruby-20f5f4816288b7344bcfaca128f32dc14a60c51a.tar.gz
ruby-20f5f4816288b7344bcfaca128f32dc14a60c51a.tar.xz
ruby-20f5f4816288b7344bcfaca128f32dc14a60c51a.zip
* math.c (math_acos): check errno after operation. ditto for
asin, acosh, atanh, log, log10 and sqrt. * eval.c (rb_add_method): initialize should always be private. * parse.y (expr): add rescue modifier rule. * parse.y (command_call): return, break and next with argument is now part of this rule. * parse.y (yylex): "a" in "a /5" should be considered as a local variable. [experimental] git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@3041 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 0 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index 1ed61aba9..7397bf983 100644
--- a/configure.in
+++ b/configure.in
@@ -464,36 +464,6 @@ fi
AC_FUNC_GETPGRP
AC_FUNC_SETPGRP
-AC_CACHE_CHECK(for working strtod, rb_cv_func_strtod,
-[AC_TRY_RUN([
-double strtod ();
-int
-main()
-{
- {
- /* Some versions of Linux strtod mis-parse strings with leading '+'. */
- char *string = " +69";
- char *term;
- double value;
- value = strtod(string, &term);
- if (value != 69 || term != (string + 4))
- exit(1);
- }
-
- {
- /* Under Solaris 2.4, strtod returns the wrong value for the
- terminating character under some conditions. */
- char *string = "NaN";
- char *term;
- strtod(string, &term);
- if (term != string && *(term - 1) == 0)
- exit(1);
- }
- exit(0);
-}
-], rb_cv_func_strtod=yes, rb_cv_func_strtod=no, rb_cv_func_strtod=no)])
-test $rb_cv_func_strtod = no && AC_LIBOBJ([strtod])
-
AC_C_BIGENDIAN
AC_C_CONST
AC_C_CHAR_UNSIGNED