summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-09 06:41:08 +0000
committerknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-09 06:41:08 +0000
commit1500060610ede3e36036bfbc86fa08f1844c1f3e (patch)
tree0b9e1f614e29010007eff002c418e5c6b979f147 /configure.in
parent135bb09a30105e2547b7750aa70b97f91e00ce9f (diff)
downloadruby-1500060610ede3e36036bfbc86fa08f1844c1f3e.tar.gz
ruby-1500060610ede3e36036bfbc86fa08f1844c1f3e.tar.xz
ruby-1500060610ede3e36036bfbc86fa08f1844c1f3e.zip
* configure.in: Add support for DragonFly BSD.
git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@6436 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5dd8cbdc1..6160643eb 100644
--- a/configure.in
+++ b/configure.in
@@ -352,6 +352,8 @@ freebsd*) LIBS="-lm $LIBS"
fi
fi
;;
+dragonfly*) LIBS="-lm $LIBS"
+ ;;
bow) ac_cv_func_setitimer=no
;;
superux*) ac_cv_func_setitimer=no
@@ -869,7 +871,7 @@ if test "$with_dln_a_out" != yes; then
gnu*) : ${LDSHARED="$CC -shared"}
rb_cv_dlopen=yes
LDFLAGS="$LDFLAGS -rdynamic" ;;
- freebsd*) : ${LDSHARED="$CC -shared"}
+ freebsd*|dragonfly*) : ${LDSHARED="$CC -shared"}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
@@ -1170,7 +1172,7 @@ if test "$enable_shared" = 'yes'; then
LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
;;
- freebsd*)
+ freebsd*|dragonfly*)
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
if test "$rb_cv_binary_elf" != "yes" ; then