summaryrefslogtreecommitdiffstats
path: root/ruby-1.9.1.spec
diff options
context:
space:
mode:
authorJeroen van Meeuwen (Fedora Unity) <kanarip@fedoraunity.org>2009-12-21 18:18:59 +0100
committerJeroen van Meeuwen (Fedora Unity) <kanarip@fedoraunity.org>2009-12-21 18:18:59 +0100
commitfd248bba6b74a4fc6d32384da1d35172f4049225 (patch)
tree9a94f826fb2c114f1911b25482d69c88cd6ff269 /ruby-1.9.1.spec
parent563d0a5c08d8e22efe163cebe1f186411b92b1a5 (diff)
downloadruby-specs-fd248bba6b74a4fc6d32384da1d35172f4049225.tar.gz
ruby-specs-fd248bba6b74a4fc6d32384da1d35172f4049225.tar.xz
ruby-specs-fd248bba6b74a4fc6d32384da1d35172f4049225.zip
Remove changelog for now
Fix ruby-1.9.1.spec missing a few files
Diffstat (limited to 'ruby-1.9.1.spec')
-rw-r--r--ruby-1.9.1.spec694
1 files changed, 16 insertions, 678 deletions
diff --git a/ruby-1.9.1.spec b/ruby-1.9.1.spec
index c13ad26..c2aec0b 100644
--- a/ruby-1.9.1.spec
+++ b/ruby-1.9.1.spec
@@ -31,12 +31,6 @@
%global _compatsuffix %{?rubymmtver:-%{rubymmtver}}
-%global ruby_sitelib %{_usr}/local/share/ruby/
-%global ruby_sitearch %{_usr}/local/%{_lib}/ruby/
-
-%global ruby_vendorlib %{_datadir}/ruby/
-%global ruby_vendorarch %{_libdir}/ruby/
-
%global _normalized_cpu %(echo `echo %{_target_cpu} | sed 's/^ppc/powerpc/'`)
Name: ruby%{?_compatsuffix}
@@ -250,10 +244,10 @@ for script in `find %{buildroot}/%{ruby_sitelib} -type f -name "*.rb"`; do
sed -r -i -e 's|(.*)/bin/ruby|%{_bindir}/ruby%{?_compatsuffix}|g' $script
done
-if [ ! -d %{buildroot}/%{_includedir}/%{name}/ ]; then
+if [ ! -d %{buildroot}/%{_includedir}/ruby%{?_compatsuffix}/ ]; then
# The headers are probably in the vendor arch dir
- mkdir -p %{buildroot}/%{_includedir}/%{name}/
- find %{buildroot}/%{ruby_vendorarch} -mindepth 1 -maxdepth 1 -type f ! -name "*.so" -exec mv -v {} %{buildroot}/%{_includedir}/%{name}/. \;
+ mkdir -p %{buildroot}/%{_includedir}/ruby%{?_compatsuffix}/
+ find %{buildroot}/%{ruby_vendorarch} -mindepth 1 -maxdepth 1 -type f ! -name "*.so" -exec mv -v {} %{buildroot}/%{_includedir}/ruby%{?_compatsuffix}/. \;
fi
%clean
rm -rf %{buildroot}
@@ -275,8 +269,12 @@ rm -rf %{buildroot}
%doc doc/ChangeLog-*
%doc doc/NEWS-*
%{_bindir}/erb%{?_compatsuffix}
+%{_bindir}/gem%{?_compatsuffix}
+%{_bindir}/rake%{?_compatsuffix}
%{_bindir}/ruby%{?_compatsuffix}
%{_bindir}/testrb%{?_compatsuffix}
+%{_mandir}/man1/erb%{?_compatsuffix}.1*
+%{_mandir}/man1/rake%{?_compatsuffix}.1*
%{_mandir}/man1/ruby%{?_compatsuffix}.1*
%files devel
@@ -287,14 +285,15 @@ rm -rf %{buildroot}
%doc LEGAL
%doc LGPL
%doc README.EXT
-%{_includedir}/ruby-%{rubyabiver}
+%{_includedir}/ruby%{?_compatsuffix}
%{_libdir}/libruby%{?_compatsuffix}.so
%files irb
%defattr(-, root, root, -)
%{_bindir}/irb%{?_compatsuffix}
-%{ruby_vendorlib}/%{?rubymmtver}/irb.rb
-%{ruby_vendorlib}/%{?rubymmtver}/irb
+%{ruby_vendorlib_191}/irb.rb
+%{ruby_vendorlib_191}/irb
+%{_mandir}/man1/irb%{?_compatsuffix}.1*
%files libs
%defattr(-, root, root, -)
@@ -305,8 +304,8 @@ rm -rf %{buildroot}
%doc LEGAL
%doc LGPL
%dir %{_datadir}/ruby
-%dir %{ruby_sitelib}/%{rubymmtver}
-%dir %{ruby_sitearch}/%{rubymmtver}
+%dir %{ruby_sitelib_191}
+%dir %{ruby_sitearch_191}
%dir %{ruby_vendorlib_191}
%{ruby_vendorarch_191}
# The following files should go into the ruby-irb package.
@@ -365,7 +364,8 @@ rm -rf %{buildroot}
%files ri
%defattr(-, root, root, -)
%{_bindir}/ri%{?_compatsuffix}
-%{_datadir}/ri/*
+%{_datadir}/ri%{?_compatsuffix}
+%{_mandir}/man1/ri%{?_compatsuffix}.1*
%files static
%defattr(-, root, root, -)
@@ -382,667 +382,5 @@ rm -rf %{buildroot}
%{ruby_vendorarch_191}/tkutil.so
%changelog
-* Sun Dec 20 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 1.8.6.383-6
-- Scare the pants off this package (and make it compat-, bwuhahaha)
+* Mon Dec 21 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 1.9.1-376-6
- New upstream version
-
-* Mon Jan 26 2009 Tomas Mraz <tmraz@redhat.com> - 1.8.6.287-3
-- rebuild with new openssl
-- BN_rand_range functions are now constified
-
-* Wed Oct 8 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.287-2
-- CVE-2008-3790: DoS vulnerability in the REXML module.
-
-* Sat Aug 23 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.287-1
-- New upstream release.
-- Security fixes.
- - CVE-2008-3655: Ruby does not properly restrict access to critical
- variables and methods at various safe levels.
- - CVE-2008-3656: DoS vulnerability in WEBrick.
- - CVE-2008-3657: Lack of taintness check in dl.
- - CVE-2008-1447: DNS spoofing vulnerability in resolv.rb.
- - CVE-2008-3443: Memory allocation failure in Ruby regex engine.
-- Remove the unnecessary backported patches.
-
-* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.8.6.230-5
-- rebuild against db4-4.7
-
-* Tue Jul 1 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.230-4
-- Backported from upstream SVN to fix a segfault issue with Array#fill.
-
-* Mon Jun 30 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.230-3
-- Backported from upstream SVN to fix a segfault issue. (#452825)
-- Backported from upstream SVN to fix an integer overflow in rb_ary_fill.
-
-* Wed Jun 25 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.230-2
-- Fix a segfault issue. (#452810)
-
-* Tue Jun 24 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.230-1
-- New upstream release.
-- Security fixes. (#452295)
- - CVE-2008-1891: WEBrick CGI source disclosure.
- - CVE-2008-2662: Integer overflow in rb_str_buf_append().
- - CVE-2008-2663: Integer overflow in rb_ary_store().
- - CVE-2008-2664: Unsafe use of alloca in rb_str_format().
- - CVE-2008-2725: Integer overflow in rb_ary_splice().
- - CVE-2008-2726: Integer overflow in rb_ary_splice().
-- ruby-1.8.6.111-CVE-2007-5162.patch: removed.
-- Build ruby-mode package for all archtectures.
-
-* Tue Mar 4 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.114-1
-- Security fix for CVE-2008-1145.
-- Improve a spec file. (#226381)
- - Correct License tag.
- - Fix a timestamp issue.
- - Own a arch-specific directory.
-
-* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.8.6.111-9
-- Autorebuild for GCC 4.3
-
-* Tue Feb 19 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.111-8
-- Rebuild for gcc-4.3.
-
-* Tue Jan 15 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.111-7
-- Revert the change of libruby-static.a. (#428384)
-
-* Fri Jan 11 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.111-6
-- Fix an unnecessary replacement for shebang. (#426835)
-
-* Fri Jan 4 2008 Akira TAGOH <tagoh@redhat.com> - 1.8.6.111-5
-- Rebuild.
-
-* Fri Dec 28 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.111-4
-- Clean up again.
-
-* Fri Dec 21 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.111-3
-- Clean up the spec file.
-- Remove ruby-man-1.4.6 stuff. this is entirely the out-dated document.
- this could be replaced by ri.
-- Disable the static library building.
-
-* Tue Dec 04 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.8.6.111-2
- - Rebuild for openssl bump
-
-* Wed Oct 31 2007 Akira TAGOH <tagoh@redhat.com>
-- Fix the dead link.
-
-* Mon Oct 29 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.111-1
-- New upstream release.
-- ruby-1.8.6.111-CVE-2007-5162.patch: Update a bit with backporting the changes
- at trunk to enable the fix without any modifications on the users' scripts.
- Note that Net::HTTP#enable_post_connection_check isn't available anymore.
- If you want to disable this post-check, you should give OpenSSL::SSL::VERIFY_NONE
- to Net::HTTP#verify_mode= instead of.
-
-* Mon Oct 15 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.110-2
-- Enable pthread support for ppc too. (#201452)
-- Fix unexpected dependencies appears in ruby-libs. (#253325)
-
-* Wed Oct 10 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.110-1
-- New upstream release.
- - ruby-r12567.patch: removed.
-- ruby-1.8.6-CVE-2007-5162.patch: security fix for Net::HTTP that is
- insufficient verification of SSL certificate.
-
-* Thu Aug 23 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.36-4
-- Rebuild
-
-* Fri Aug 10 2007 Akira TAGOH <tagoh@redhat.com>
-- Update License tag.
-
-* Mon Jul 25 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.36-3
-- ruby-r12567.patch: backport patch from upstream svn to get rid of
- the unnecessary declarations. (#245446)
-
-* Wed Jul 20 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6.36-2
-- New upstream release.
- - Fix Etc::getgrgid to get the correct gid as requested. (#236647)
-
-* Wed Mar 28 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6-2
-- Fix search path breakage. (#234029)
-
-* Thu Mar 15 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.6-1
-- New upstream release.
-- clean up a spec file.
-
-* Tue Feb 13 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.5.12-2
-- Rebuild
-
-* Mon Feb 5 2007 Akira TAGOH <tagoh@redhat.com> - 1.8.5.12-1
-- New upstream release.
-
-* Mon Dec 11 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.5.2-1
-- security fix release.
-
-* Fri Oct 27 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.5-4
-- security fix release.
-- ruby-1.8.5-cgi-CVE-2006-5467.patch: fix a CGI multipart parsing bug that
- causes the denial of service. (#212396)
-
-* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.8.5-3
-- rebuilt for unwind info generation, broken in gcc-4.1.1-21
-
-* Tue Sep 26 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.5-2
-- fixed rbconfig.rb to refer to DESTDIR for sitearchdir. (#207311)
-
-* Mon Aug 28 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.5-1
-- New upstream release.
-- removed the unnecessary patches:
- - ruby-1.8.4-no-eaccess.patch
- - ruby-1.8.4-64bit-pack.patch
- - ruby-1.8.4-fix-insecure-dir-operation.patch
- - ruby-1.8.4-fix-insecure-regexp-modification.patch
- - ruby-1.8.4-fix-alias-safe-level.patch
-- build with --enable-pthread except on ppc.
-- ruby-1.8.5-hash-memory-leak.patch: backported from CVS to fix a memory leak
- on Hash. [ruby-talk:211233]
-
-* Mon Aug 7 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-12
-- owns sitearchdir. (#201208)
-
-* Thu Jul 20 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-11
-- security fixes [CVE-2006-3694]
- - ruby-1.8.4-fix-insecure-dir-operation.patch:
- - ruby-1.8.4-fix-insecure-regexp-modification.patch: fixed the insecure
- operations in the certain safe-level restrictions. (#199538)
- - ruby-1.8.4-fix-alias-safe-level.patch: fixed to not bypass the certain
- safe-level restrictions. (#199543)
-
-* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.8.4-10.fc6.1
-- rebuild
-
-* Mon Jun 19 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-10
-- fixed the wrong file list again. moved tcltk library into ruby-tcltk.
- (#195872)
-
-* Thu Jun 8 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-8
-- ruby-deprecated-sitelib-search-path.patch: correct the order of search path.
-
-* Wed Jun 7 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-7
-- exclude ppc64 to make ruby-mode package. right now emacs.ppc64 isn't provided
- and buildsys became much stricter.
-- ruby-deprecated-sitelib-search-path.patch: applied to add more search path
- for backward compatiblity.
-- added byacc to BuildReq. (#194161)
-
-* Wed May 17 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-6
-- ruby-deprecated-search-path.patch: added the deprecated installation paths
- to the search path for the backward compatibility.
-- added a Provides: ruby(abi) to ruby-libs.
-- ruby-1.8.4-64bit-pack.patch: backport patch from upstream to fix unpack("l")
- not working on 64bit arch and integer overflow on template "w". (#189350)
-- updated License tag to be more comfortable, and with a pointer to get more
- details, like Python package does. (#179933)
-- clean up.
-
-* Wed Apr 19 2006 Akira TAGOH <tagoh@redhat.com>
-- ruby-rubyprefix.patch: moved all arch-independent modules under /usr/lib/ruby
- and keep arch-dependent modules under /usr/lib64/ruby for 64bit archs.
- so 'rubylibdir', 'sitelibdir' and 'sitedir' in Config::CONFIG points to
- the kind of /usr/lib/ruby now. (#184199)
-
-* Mon Apr 17 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-4
-- correct sitelibdir. (#184198)
-
-* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.8.4-3.2
-- bump again for double-long bug on ppc(64)
-
-* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.8.4-3.1
-- rebuilt for new gcc4.1 snapshot and glibc changes
-
-* Mon Feb 6 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-3
-- ruby-1.8.4-no-eaccess.patch: backported from ruby CVS to avoid conflict
- between newer glibc. (#179835)
-
-* Wed Jan 4 2006 Akira TAGOH <tagoh@redhat.com> - 1.8.4-2
-- ruby-tcltk-multilib.patch: fixed a typo.
-
-* Tue Dec 27 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.4-1
-- New upstream release.
- - fixed a missing return statement. (#140833)
- - fixed an use of uninitialized variable. (#144890)
-
-* Fri Dec 16 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.4-0.4.preview2
-- updates to 1.8.4-preview2.
-- renamed the packages to ruby-* (#175765)
- - irb -> ruby-irb
- - rdoc -> ruby-rdoc
- - ri -> ruby-ri
-- added tcl-devel and tk-devel into BuildRequires.
-
-* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
-- rebuilt
-
-* Thu Nov 10 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.4-0.3.preview1
-- rebuilt against the latest openssl.
-
-* Tue Nov 1 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.4-0.2.preview1
-- build-deps libX11-devel instead of xorg-x11-devel.
-
-* Mon Oct 31 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.4-0.1.preview1
-- New upstream release.
-- ruby-1.8.2-strscan-memset.patch: removed because it's no longer needed.
-
-* Tue Oct 4 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.3-4
-- moved the documents from ruby-libs to ruby-docs, which contains the arch
- specific thing and to be multilib support. (#168826)
-
-* Mon Oct 3 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.3-3
-- fixed the wrong file list. the external library for tcl/tk was included
- in ruby-libs unexpectedly.
-
-* Mon Sep 26 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.3-2
-- ruby-multilib.patch: added another chunk for multilib. (#169127)
-
-* Wed Sep 21 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.3-1
-- New upstream release.
-- Build-Requires xorg-x11-devel instead of XFree86-devel.
-- ruby-multilib.patch: applied for only 64-bit archs.
-- ruby-1.8.2-xmlrpc-CAN-2005-1992.patch: removed. it has already been in upstream.
-
-* Tue Jun 21 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-9
-- ruby-1.8.2-xmlrpc-CAN-2005-1992.patch: fixed the arbitrary command execution
- on XMLRPC server. (#161096)
-
-* Thu Jun 16 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-8
-- ruby-1.8.2-tcltk-multilib.patch: applied to get tcltklib.so built. (#160194)
-
-* Thu Apr 7 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-7
-- ruby-1.8.2-deadcode.patch: removed the dead code from the source. (#146108)
-- make sure that all documentation files in ruby-docs are the world-
- readable. (#147279)
-
-* Tue Mar 22 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-6
-- ruby-1.8.2-strscan-memset.patch: fixed an wrong usage of memset(3).
-
-* Tue Mar 15 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-5
-- rebuilt
-
-* Tue Jan 25 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-4
-- fixed the wrong generation of file manifest. (#146055)
-- spec file clean up.
-
-* Mon Jan 24 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-3
-- separated out to rdoc package.
-- make the dependency of irb for rdoc. (#144708)
-
-* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1.8.2-2
-- Rebuilt for new readline.
-
-* Wed Jan 5 2005 Akira TAGOH <tagoh@redhat.com> - 1.8.2-1
-- New upstream release.
-- ruby-1.8.1-ia64-stack-limit.patch: removed - it's no longer needed.
-- ruby-1.8.1-cgi_session_perms.patch: likewise.
-- ruby-1.8.1-cgi-dos.patch: likewise.
-- generated Ruby interactive documentation - senarated package.
- it's now provided as ri package. (#141806)
-
-* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 1.8.1-10
-- rebuild against db-4.3.21.
-
-* Wed Nov 10 2004 Akira TAGOH <tagoh@redhat.com> - 1.8.1-9
-- ruby-1.8.1-cgi-dos.patch: security fix [CAN-2004-0983]
-- ruby-1.8.1-cgi_session_perms.patch: security fix [CAN-2004-0755]
-
-* Fri Oct 29 2004 Akira TAGOH <tagoh@redhat.com> - 1.8.1-8
-- added openssl-devel and db4-devel into BuildRequires (#137479)
-
-* Wed Oct 6 2004 Akira TAGOH <tagoh@redhat.com> - 1.8.1-7
-- require emacs-common instead of emacs.
-
-* Wed Jun 23 2004 Akira TAGOH <tagoh@redhat.com> 1.8.1-4
-- updated the documentation.
-
-* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
-- rebuilt
-
-* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
-- rebuilt
-
-* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
-- rebuilt
-
-* Wed Feb 04 2004 Akira TAGOH <tagoh@redhat.com> 1.8.1-1
-- New upstream release.
-- don't use any optimization for ia64 to avoid the build failure.
-- ruby-1.8.1-ia64-stack-limit.patch: applied to fix SystemStackError when the optimization is disabled.
-
-* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 1.8.0-3
-- rebuild against db-4.2.52.
-
-* Thu Sep 25 2003 Jeff Johnson <jbj@jbj.org> 1.8.0-2
-- rebuild against db-4.2.42.
-
-* Tue Aug 5 2003 Akira TAGOH <tagoh@redhat.com> 1.8.0-1
-- New upstream release.
-
-* Thu Jul 24 2003 Akira TAGOH <tagoh@redhat.com> 1.6.8-9.1
-- rebuilt
-
-* Thu Jul 24 2003 Akira TAGOH <tagoh@redhat.com> 1.6.8-9
-- ruby-1.6.8-castnode.patch: handling the nodes with correct cast.
- use this patch now instead of ruby-1.6.8-fix-x86_64.patch.
-
-* Fri Jul 04 2003 Akira TAGOH <tagoh@redhat.com> 1.6.8-8
-- rebuilt
-
-* Fri Jul 04 2003 Akira TAGOH <tagoh@redhat.com> 1.6.8-7
-- fix the gcc warnings. (#82192)
-- ruby-1.6.8-fix-x86_64.patch: correct a patch.
- NOTE: DON'T USE THIS PATCH FOR BIG ENDIAN ARCHITECTURE.
-- ruby-1.6.7-long2int.patch: removed.
-
-* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
-- rebuilt
-
-* Fri Feb 7 2003 Jens Petersen <petersen@redhat.com> - 1.6.8-5
-- rebuild against ucs4 tcltk
-
-* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
-- rebuilt
-
-* Wed Jan 22 2003 Akira TAGOH <tagoh@redhat.com> 1.6.8-3
-- ruby-1.6.8-multilib.patch: applied to fix the search path issue on x86_64
-
-* Tue Jan 21 2003 Akira TAGOH <tagoh@redhat.com> 1.6.8-2
-- ruby-1.6.8-require.patch: applied to fix the search bug in require.
-- don't apply long2int patch to s390 and s390x. it doesn't work.
-
-* Wed Jan 15 2003 Akira TAGOH <tagoh@redhat.com> 1.6.8-1
-- New upstream release.
-- removed some patches. it's no longer needed.
- - ruby-1.6.7-100.patch
- - ruby-1.6.7-101.patch
- - ruby-1.6.7-102.patch
- - ruby-1.6.7-103.patch
- - 801_extmk.rb-shellwords.patch
- - 801_mkmf.rb-shellwords.patch
- - 804_parse.y-new-bison.patch
- - 805_uri-bugfix.patch
- - ruby-1.6.6-900_XXX_strtod.patch
- - ruby-1.6.7-sux0rs.patch
- - ruby-1.6.7-libobj.patch
-
-* Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 1.6.7-14
-- rebuild to update tcltk deps
-
-* Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 1.6.7-13
-- Remove ExcludeArch: x86_64
-- Fix x86_64 ruby with long2int.patch (ruby was assuming that sizeof(long)
- == sizeof(int). The patch does not fix the source of the problem, just
- makes it a non-issue.)
-- _smp_mflags
-
-* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 1.6.7-12
-- rebuild to fix broken tcltk deps
-
-* Tue Oct 22 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-11
-- use %%configure macro instead of configure script.
-- use the latest config.{sub,guess}.
-- get archname from rbconfig.rb for %%dir
-- applied some patches from Debian:
- - 801_extmk.rb-shellwords.patch: use Shellwords
- - 801_mkmf.rb-shellwords.patch: mkmf.rb creates bad Makefile. the Makefile
- links libruby.a to the target.
- - 803_sample-fix-shbang.patch: all sample codes should be
- s|/usr/local/bin|/usr/bin|g
- - 804_parse.y-new-bison.patch: fix syntax warning.
- - 805_uri-bugfix.patch: uri.rb could not handle correctly broken mailto-uri.
-- add ExcludeArch x86_64 temporarily to fix Bug#74581. Right now ruby can't be
- built on x86_64.
-
-* Tue Aug 27 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-10
-- moved sitedir to /usr/lib/ruby/site_ruby again according as our perl and
- python.
-- ruby-1.6.7-resolv1.patch, ruby-1.6.7-resolv2.patch: applied to fix 'Too many
- open files - "/etc/resolv.conf"' issue. (Bug#64830)
-
-* Thu Jul 18 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-9
-- add the owned directory.
-
-* Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-8
-- fix typo.
-
-* Thu Jul 04 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-7
-- removed the ruby-mode-xemacs because it's merged to the xemacs sumo.
-
-* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
-- automated rebuild
-
-* Wed Jun 19 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-5
-- fix the stripped binary.
-- use the appropriate macros.
-
-* Sun May 26 2002 Tim Powers <timp@redhat.com>
-- automated rebuild
-
-* Thu May 23 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-3
-- ruby-1.6.7-libobj.patch: applied to fix autoconf2.53 error.
-
-* Mon Mar 18 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-2
-- ruby-man-1.4.6-jp.tar.bz2: removed.
-- ruby-refm-rdp-1.4.7-ja-html.tar.bz2: uses it instead of.
-- ruby-1.6.7-500-marshal-proc.patch, ruby-1.6.7-501-class-var.patch:
- removed.
-- ruby-1.6.7-100.patch: applied a bug fix patch.
- (ruby-dev#16274: patch for 'wm state')
- (PR#206ja: SEGV handle EXIT)
-- ruby-1.6.7-101.patch: applied a bug fix patch.
- (ruby-list#34313: singleton should not be Marshal.dump'ed)
- (ruby-dev#16411: block local var)
-- ruby-1.6.7-102.patch: applied a bug fix patch.
- (handling multibyte chars is partially broken)
-- ruby-1.6.7-103.patch: applied a bug fix patch.
- (ruby-dev#16462: preserve reference for GC, but link should be cut)
-
-* Fri Mar 8 2002 Akira TAGOH <tagoh@redhat.com> 1.6.7-1
-- New upstream release.
-- ruby-1.6.6-100.patch, ruby-1.6.6-501-ruby-mode.patch:
- removed. these patches no longer should be needed.
-- ruby-1.6.7-500-marshal-proc.patch: applied a fix patch.
- (ruby-dev#16178: Marshal::dump should call Proc#call.)
-- ruby-1.6.7-501-class-var.patch: applied a fix patch.
- (ruby-talk#35157: class vars broken in 1.6.7)
-
-* Wed Feb 27 2002 Akira TAGOH <tagoh@redhat.com> 1.6.6-5
-- Disable alpha because nothing is xemacs for alpha now.
-
-* Tue Feb 5 2002 Akira TAGOH <tagoh@redhat.com> 1.6.6-3
-- Fixed the duplicate files.
-
-* Tue Feb 5 2002 Akira TAGOH <tagoh@redhat.com> 1.6.6-2
-- Fixed the missing %%defattr
-
-* Fri Feb 1 2002 Akira TAGOH <tagoh@redhat.com> 1.6.6-1
-- New upstream release.
-- Applied bug fix patches:
- - ruby-1.6.6-501-ruby-mode.patch: ruby-talk#30479: disables font-lock
- coloring.
- - ruby-1.6.6-100.patch: ruby-talk#30203: Ruby 1.6.6 bug and fix
- ruby-list#33047: regex bug
- PR#230: problem with -d in 1.6.6
-- Added ruby-mode and ruby-mode-xemacs packages.
-- Ruby works fine for ia64. so re-enable to build with ia64.
- (probably it should be worked for alpha)
-
-* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
-- automated rebuild
-
-* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.6.4-2
-- Remove Japanese description and summaries; they belong in specspo and
- break rpm
-- Clean up specfile
-- Mark language specific files (README.jp) as such
-- bzip2 sources
-- rename the libruby package to ruby-libs for consistency
-- Exclude ia64 (doesn't build - the code doesn't seem to be 64-bit clean
- [has been excluded on alpha forever])
-
-* Tue Jul 17 2001 Akira TAGOH <tagoh@redhat.com> 1.6.4-1
-- rebuild for Red Hat 7.2
-
-* Mon Jun 04 2001 akira yamada <akira@vinelinux.org>
-- upgrade to nwe upstream version 1.6.4.
-
-* Mon Apr 02 2001 akira yamada <akira@vinelinux.org>
-- applied patch:
- - fixed method cache bug. etc. (Patch103, Patch104)
-
-* Tue Mar 27 2001 akira yamada <akira@vinelinux.org>
-- applied patch:
- - fixed marshal for bignum bug.
- - fixed scope of constant variables bug.
-
-* Tue Mar 20 2001 akira yamada <akira@vinelinux.org>
-- upgraded to new upstream version 1.6.3.
-
-* Fri Feb 09 2001 akira yamada <akira@vinelinux.org>
-- fixed bad group for libruby.
-- Applied patch: upgraded to cvs version (2001-02-08):
- fixed minor bugs.
-
-* Thu Jan 18 2001 akira yamada <akira@vinelinux.org>
-- Applied patch: upgraded to cvs version (2001-01-15):
- fixed minor bugs(e.g. ruby makes extention librares too large...).
-
-* Wed Jan 10 2001 akira yamada <akira@vinelinux.org>
-- Applied patch: upgraded to cvs version (2001-01-09):
- fixed minor bugs.
-
-* Sat Dec 30 2000 akira yamada <akira@vinelinux.org>
-- Applied bug fix patch.
-
-* Mon Dec 25 2000 akira yamada <akira@vinelinux.org>
-- Updated to new upstream version 1.6.2.
-
-* Fri Dec 22 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000122019.patch, added ruby_cvs.2000122215.patch
- (upgraded ruby to latest cvs version, 1.6.2-preview4).
-
-* Wed Dec 20 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000121413.patch, added ruby_cvs.2000122019.patch
- (upgraded ruby to latest cvs version).
-- new package: libruby
-
-* Thu Dec 14 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000101901.patch, added ruby_cvs.2000121413.patch
- (upgraded ruby to latest cvs version).
-- Removed ruby-dev.11262.patch, ruby-dev.11265.patch,
- and ruby-dev.11268.patch (included into above patch).
-
-* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.6.1-0vl9
-- build on gcc-2.95.3
-
-* Thu Oct 19 2000 akira yamada <akira@vinelinux.org>
-- Added ruby-dev.11268.patch.
-
-* Thu Oct 19 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000101117.patch and added ruby_cvs.2000101901.patch
- (upgraded ruby to latest cvs version).
-- Added ruby-dev.11262.patch.
-- Added ruby-dev.11265.patch.
-
-* Wed Oct 11 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000100313.patch and added ruby_cvs.2000101117.patch
- (upgraded ruby to latest cvs version).
-
-* Mon Oct 09 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000100313.patch and added ruby_cvs.2000100313.patch
- (upgraded ruby to latest cvs version).
-
-* Tue Oct 03 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000100218.patch and added ruby_cvs.2000100313.patch
- (upgraded ruby to latest cvs version).
-
-* Mon Oct 02 2000 akira yamada <akira@vinelinux.org>
-- Removed ruby_cvs.2000092718.patch and added ruby_cvs.2000100218.patch
- (upgraded ruby to latest cvs version).
-
-* Thu Sep 27 2000 akira yamada <akira@vinelinux.org>
-- Updated to upstream version 1.6.1.
-- Removed ruby_cvs.2000082901.patch and added ruby_cvs.2000092718.patch
- (upgraded ruby to latest cvs version).
-
-* Tue Aug 29 2000 akira yamada <akira@redhat.com>
-- Updated to version 1.4.6.
-- removed ruby-dev.10123.patch(included into ruby-1.4.6).
-- Added ruby_cvs.2000082901.patch(upgraded ruby to latest cvs version).
-
-* Tue Jun 27 2000 akira yamada <akira@redhat.com>
-- Updated manuals to version 1.4.5.
-
-* Sun Jun 25 2000 akira yamada <akira@redhat.com>
-- Added ruby-dev.10123.patch.
-
-* Sat Jun 24 2000 akira yamada <akira@redhat.com>
-- Updated to version 1.4.5.
-- Removed ruby_cvs.2000062401.patch(included into ruby-1.4.5).
-
-* Thu Jun 22 2000 akira yamada <akira@redhat.com>
-- Updated to version 1.4.4(06/22/2000 CVS).
-- Removed ruby-dev.10054.patch(included into ruby_cvs.patch).
-
-* Thu Jun 22 2000 akira yamada <akira@redhat.com>
-- Renamed to ruby_cvs20000620.patch from ruby_cvs.patch.
-
-* Tue Jun 20 2000 akira yamada <akira@redhat.com>
-- Updated to version 1.4.4(06/20/2000 CVS).
-- Removed ruby-list.23190.patch(included into ruby_cvs.patch).
-- Added ruby-dev.10054.patch.
-
-* Tue Jun 15 2000 akira yamada <akira@redhat.com>
-- Updated to version 1.4.4(06/12/2000 CVS).
-- Added manuals and FAQs.
-- Split into ruby, ruby-devel, ruby-tcltk, ruby-docs, irb.
-
-* Tue Jun 13 2000 Mitsuo Hamada <mhamada@redhat.com>
-- Updated to version 1.4.4
-
-* Wed Dec 08 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- Updated to version 1.4.3
-
-* Mon Sep 20 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- Updated to version 1.4.2 (Sep 18)
-
-* Fri Sep 17 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- Updated to version 1.4.2
-
-* Tue Aug 17 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- Updated to version 1.4.0
-
-* Fri Jul 23 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- 2nd release
-- Updated to version 1.2.6(15 Jul 1999)
-- striped %%{prefix}/bin/ruby
-
-* Mon Jun 28 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- Updated to version 1.2.6(21 Jun 1999)
-
-* Wed Apr 14 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- Updated to version 1.2.5
-
-* Fri Apr 09 1999 Atsushi Yamagata <yamagata@plathome.co.jp>
-- Updated to version 1.2.4
-
-* Fri Dec 25 1998 Toru Hoshina <hoshina@best.com>
-- Version up to 1.2 stable.
-
-* Fri Nov 27 1998 Toru Hoshina <hoshina@best.com>
-- Version up to 1.1c9.
-
-* Thu Nov 19 1998 Toru Hoshina <hoshina@best.com>
-- Version up to 1.1c8, however it appear short life :-P
-
-* Fri Nov 13 1998 Toru Hoshina <hoshina@best.com>
-- Version up.
-
-* Mon Sep 22 1998 Toru Hoshina <hoshina@best.com>
-- To make a libruby.so.
-
-* Mon Sep 21 1998 Toru Hoshina <hoshina@best.com>
-- Modified SPEC in order to install libruby.a so that it should be used by
- another ruby entention.
-- 2nd release.
-
-* Mon Mar 9 1998 Shoichi OZAWA <shoch@jsdi.or.jp>
-- Added a powerPC arch part. Thanks, MURATA Nobuhiro <nob@makioka.y-min.or.jp>