summaryrefslogtreecommitdiffstats
path: root/facter.spec
diff options
context:
space:
mode:
authorJeroen van Meeuwen (Fedora Unity) <kanarip@fedoraunity.org>2009-12-28 01:48:25 +0100
committerJeroen van Meeuwen (Fedora Unity) <kanarip@fedoraunity.org>2009-12-28 01:48:25 +0100
commite3c49279d133ae31a360e45edce0cd4651d90fe3 (patch)
tree70fb471c864aef092a4d4f3979682a44d59774fb /facter.spec
parente052833c52e33f9e41c26bcab27bc63f85337c94 (diff)
downloadruby-specs-e3c49279d133ae31a360e45edce0cd4651d90fe3.tar.gz
ruby-specs-e3c49279d133ae31a360e45edce0cd4651d90fe3.tar.xz
ruby-specs-e3c49279d133ae31a360e45edce0cd4651d90fe3.zip
Add facter.spec
Diffstat (limited to 'facter.spec')
-rw-r--r--facter.spec149
1 files changed, 149 insertions, 0 deletions
diff --git a/facter.spec b/facter.spec
new file mode 100644
index 0000000..74e5af0
--- /dev/null
+++ b/facter.spec
@@ -0,0 +1,149 @@
+%define has_ruby_abi 0%{?fedora} || 0%{?rhel} >= 5
+%define has_ruby_noarch %has_ruby_abi
+
+Summary: Ruby module for collecting simple facts about a host operating system
+Name: facter
+Version: 1.5.7
+Release: 1%{?dist}
+License: GPLv2+
+Group: System Environment/Base
+URL: http://reductivelabs.com/projects/facter
+Source0: http://reductivelabs.com/downloads/facter/%{name}-%{version}.tar.gz
+
+# Bugzilla 508037, or upstream ticket 2355 (drop in 1.6.0)
+Patch0: facter-1.5.7-facts-hanging-on-_proc_xen_capabilities.patch
+
+Patch1: facter-1.5.7-ftools-becomes-filetools-ruby-1.9.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+%if %has_ruby_noarch
+BuildArch: noarch
+%endif
+
+Requires: ruby >= 1.8.1
+Requires: which
+%if %has_ruby_abi
+Requires: ruby(abi) >= 1.8
+%endif
+BuildRequires: ruby >= 1.8.1
+
+%description
+Ruby module for collecting simple facts about a host Operating
+system. Some of the facts are preconfigured, such as the hostname and the
+operating system. Additional facts can be added through simple Ruby scripts
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+
+%install
+rm -rf %{buildroot}
+ruby install.rb --destdir=%{buildroot} --quick --no-rdoc \
+ --sitelibdir=%{ruby_vendorlib}
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{_bindir}/facter
+%{ruby_vendorlib}/facter.rb
+%{ruby_vendorlib}/facter
+%doc CHANGELOG COPYING INSTALL LICENSE README
+
+%changelog
+* Fri Sep 25 2009 Todd Zullinger <tmz@pobox.com> - 1.5.7-1
+- Update to 1.5.7
+- Update #508037 patch from upstream ticket
+
+* Wed Aug 12 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 1.5.5-3
+- Fix #508037 or upstream #2355
+
+* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Fri May 22 2009 Todd Zullinger <tmz@pobox.com> - 1.5.5-1
+- Update to 1.5.5
+- Drop upstreamed libperms patch
+
+* Sat Feb 28 2009 Todd Zullinger <tmz@pobox.com> - 1.5.4-1
+- New version
+- Use upstream install script
+
+* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Tue Sep 09 2008 Todd Zullinger <tmz@pobox.com> - 1.5.2-1
+- New version
+- Simplify spec file checking for Fedora and RHEL versions
+
+* Mon Sep 8 2008 David Lutterkort <dlutter@redhat.com> - 1.5.1-1
+- New version
+
+* Thu Jul 17 2008 David Lutterkort <dlutter@redhat.com> - 1.5.0-3
+- Change 'mkdir' in install to 'mkdir -p'
+
+* Thu Jul 17 2008 David Lutterkort <dlutter@redhat.com> - 1.5.0-2
+- Remove files that were listed twice in files section
+
+* Mon May 19 2008 James Turnbull <james@lovedthanlosty.net> - 1.5.0-1
+- New version
+- Added util and plist files
+
+* Mon Sep 24 2007 David Lutterkort <dlutter@redhat.com> - 1.3.8-1
+- Update license tag
+- Copy all of lib/ into ruby_sitelibdir
+
+* Thu Mar 29 2007 David Lutterkort <dlutter@redhat.com> - 1.3.7-1
+- New version
+
+* Fri Jan 19 2007 David Lutterkort <dlutter@redhat.com> - 1.3.6-1
+- New version
+
+* Thu Jan 18 2007 David Lutterkort <dlutter@redhat.com> - 1.3.5-3
+- require which; facter is very unhappy without it
+
+* Mon Nov 20 2006 David Lutterkort <dlutter@redhat.com> - 1.3.5-2
+- Make require ruby(abi) and buildarch: noarch conditional for fedora 5 or
+ later to allow building on older fedora releases
+
+* Tue Oct 10 2006 David Lutterkort <dlutter@redhat.com> - 1.3.5-1
+- New version
+
+* Tue Sep 26 2006 David Lutterkort <dlutter@redhat.com> - 1.3.4-1
+- New version
+
+* Wed Sep 13 2006 David Lutterkort <dlutter@redhat.com> - 1.3.3-2
+- Rebuilt for FC6
+
+* Wed Jun 28 2006 David Lutterkort <dlutter@redhat.com> - 1.3.3-1
+- Rebuilt
+
+* Fri Jun 19 2006 Luke Kanies <luke@madstop.com> - 1.3.0-1
+- Fixed spec file to work again with the extra memory and processor files.
+- Require ruby(abi). Build as noarch
+
+* Fri Jun 9 2006 Luke Kanies <luke@madstop.com> - 1.3.0-1
+- Added memory.rb and processor.rb
+
+* Mon Apr 17 2006 David Lutterkort <dlutter@redhat.com> - 1.1.4-4
+- Rebuilt with changed upstream tarball
+
+* Tue Mar 21 2006 David Lutterkort <dlutter@redhat.com> - 1.1.4-3
+- Do not rely on install.rb, it will be deleted upstream
+
+* Mon Mar 13 2006 David Lutterkort <dlutter@redhat.com> - 1.1.4-2
+- Commented out noarch; requires fix for bz184199
+
+* Mon Mar 6 2006 David Lutterkort <dlutter@redhat.com> - 1.1.4-1
+- Removed unused macros
+
+* Mon Feb 6 2006 David Lutterkort <dlutter@redhat.com> - 1.1.1-2
+- Fix BuildRoot. Add dist to release tag
+
+* Wed Jan 11 2006 David Lutterkort <dlutter@redhat.com> - 1.1.1-1
+- Initial build.