summaryrefslogtreecommitdiffstats
path: root/balbir/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'balbir/configure.in')
-rw-r--r--balbir/configure.in64
1 files changed, 0 insertions, 64 deletions
diff --git a/balbir/configure.in b/balbir/configure.in
deleted file mode 100644
index f9c37d3..0000000
--- a/balbir/configure.in
+++ /dev/null
@@ -1,64 +0,0 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-#
-# Copyright International Business Machines Corp. 2008
-#
-# Authors: Balbir Singh <balbir@linux.vnet.ibm.com>
-# This program is free software; you can redistribute it and/or modify it
-# under the terms of version 2.1 of the GNU Lesser General Public License
-# as published by the Free Software Foundation.
-#
-# This program is distributed in the hope that it would be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-#
-AC_PREREQ(2.61)
-AC_INIT([control groups library and utilities], 0.1b,
- [http://sourceforge.net/tracker/?group_id=218421&atid=1043649])
-AC_CONFIG_SRCDIR([wrapper.c])
-AC_CONFIG_HEADER([config.h])
-
-# Checks for programs.
-AC_PROG_CXX
-AC_PROG_CC
-AC_PROG_YACC
-if test "$YACC" != byacc; then
- YACC="$SHELL $missing_dir/missing byacc"
- AC_SUBST(YACC, "byacc")
-fi
-AC_PROG_LEX
-AC_PROG_MKDIR_P
-if test "$INSTALL" != install; then
- AC_SUBST(INSTALL, "install")
-fi
-AC_PROG_INSTALL
-
-# Checks for libraries.
-# FIXME: Replace `main' with a function in `-lcgroup':
-AC_CHECK_LIB([cgroup], [cgroup_create_cgroup])
-
-# Checks for header files.
-AC_HEADER_DIRENT
-AC_HEADER_STDC
-AC_CHECK_HEADERS([limits.h mntent.h stdlib.h string.h sys/mount.h unistd.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_CONST
-AC_TYPE_UID_T
-AC_C_INLINE
-AC_TYPE_INT64_T
-AC_TYPE_PID_T
-
-# Checks for library functions.
-AC_FUNC_CHOWN
-AC_FUNC_GETMNTENT
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
-AC_FUNC_STAT
-AC_CHECK_FUNCS([getmntent hasmntopt memset mkdir rmdir strdup])
-
-AC_CONFIG_FILES([Makefile])
-AC_CONFIG_FILES([libcgroup.spec:libcgroup.spec.in])
-AC_CONFIG_FILES([mktarball:mktarball.in])
-AC_OUTPUT