summaryrefslogtreecommitdiffstats
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-05-25 09:48:34 +0200
committerJan Safranek <jsafrane@redhat.com>2009-05-25 09:48:34 +0200
commit62e5d793d3d34479fec591dee62854381dc51291 (patch)
tree1c5ee0a288a5c6da051745df1df5eca7a7e3ec43 /src/daemon/Makefile.am
parent4a79706ce7f2e24dc7a028a42d2311aa885d77c3 (diff)
downloadlibcg-62e5d793d3d34479fec591dee62854381dc51291.tar.gz
libcg-62e5d793d3d34479fec591dee62854381dc51291.tar.xz
libcg-62e5d793d3d34479fec591dee62854381dc51291.zip
Add options to enable/disable various build targets.
By default, everything is compiled. I want to add options to ./configure, which can selectively disable tools, daemon and pam module. The library itself is mandatory component and cannot be disabled. Usage: ./configure --help ./configure --disable-tools --disable-pam --disable-daemon Signed-off-by: Jan Safranek <jsafrane@redhat.com>
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index f0c9b92..feeeb3a 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -1,6 +1,10 @@
INCLUDES = -I $(top_srcdir)/include
-sbin_PROGRAMS = cgrulesengd
+if WITH_DAEMON
+
+sbin_PROGRAMS = cgrulesengd
cgrulesengd_SOURCES = cgrulesengd.c cgrulesengd.h
cgrulesengd_LDADD = $(top_srcdir)/src/.libs/libcgroup.la -lrt
cgrulesengd_LDFLAGS = -L$(top_srcdir)/src/.libs
+
+endif