summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-03-26 15:10:09 +0100
committerJan Safranek <jsafrane@redhat.com>2009-03-26 15:10:09 +0100
commitb5a9d8553bd1fa47ba354bf52b4adc03d070b1e3 (patch)
tree4960a21e5ed8778d8554dec231421bbfa12c4f80 /src/Makefile.am
parent5d17fc1d7f60abd35f852706bef06411a963caa3 (diff)
downloadlibcg-b5a9d8553bd1fa47ba354bf52b4adc03d070b1e3.tar.gz
libcg-b5a9d8553bd1fa47ba354bf52b4adc03d070b1e3.tar.xz
libcg-b5a9d8553bd1fa47ba354bf52b4adc03d070b1e3.zip
Rework the way how so version is defined
Make the shared object version a bit more usable, the notation with double colons cannot be used on different places (see next patch). Also run automake && autoconf to refresh the generated stuff. Signed-off-by: Jan Safranek <jsafrane@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c30393a..93d07e9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,5 +7,6 @@ INCLUDES = -I$(top_srcdir)/include
lib_LTLIBRARIES = libcgroup.la
libcgroup_la_SOURCES = parse.y lex.l api.c config.c libcgroup-internal.h libcgroup.map wrapper.c
libcgroup_la_LIBADD = -lpthread
-libcgroup_la_LDFLAGS = -Wl,--version-script,libcgroup.map -version-number $(LIBRARY_VERSION)
+libcgroup_la_LDFLAGS = -Wl,--version-script,libcgroup.map -version-number \
+ -version-number $(LIBRARY_VERSION_MAJOR):$(LIBRARY_VERSION_MINOR):$(LIBRARY_VERSION_RELEASE)