summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-03-13 15:16:20 +0100
committerJan Safranek <jsafrane@redhat.com>2009-03-26 09:36:41 +0100
commit07ff50e0856fecd937fb6a5ce87871f19f20f004 (patch)
treed35b0a391af1bc48d0b9ec7e9cd7f138a2126f58 /src/Makefile.am
parentb64a3c84e46550df4455ef4e46ec5d3b36486d65 (diff)
downloadlibcg-07ff50e0856fecd937fb6a5ce87871f19f20f004.tar.gz
libcg-07ff50e0856fecd937fb6a5ce87871f19f20f004.tar.xz
libcg-07ff50e0856fecd937fb6a5ce87871f19f20f004.zip
Add automake makefiles
Add automake makefiles and prepare everything to run, but don't actually run the automake - it would generate lot of noise, where my manual changes would get lots. Signed-off-by: Jan Safranek <jsafrane@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c30393a
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,11 @@
+SUBDIRS = . daemon pam tools
+
+# generate parse.h from parse.y
+AM_YFLAGS = -d
+
+INCLUDES = -I$(top_srcdir)/include
+lib_LTLIBRARIES = libcgroup.la
+libcgroup_la_SOURCES = parse.y lex.l api.c config.c libcgroup-internal.h libcgroup.map wrapper.c
+libcgroup_la_LIBADD = -lpthread
+libcgroup_la_LDFLAGS = -Wl,--version-script,libcgroup.map -version-number $(LIBRARY_VERSION)
+