summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-10-19 19:15:52 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-10-29 10:55:11 +0100
commitdde29ee9e0f9600453c360dc8544ef9beb07ea6c (patch)
tree92602a659827be895bd390b9f23fdbc762840ed2 /Makefile.am
parentc3209dd39a117898541285fe0c891f0d4b676598 (diff)
downloadsssd-dde29ee9e0f9600453c360dc8544ef9beb07ea6c.tar.gz
sssd-dde29ee9e0f9600453c360dc8544ef9beb07ea6c.tar.xz
sssd-dde29ee9e0f9600453c360dc8544ef9beb07ea6c.zip
LDAP: Drop privileges after kinit in ldap_child
After ldap_child initializes privileges using root-owned keytab, it drops privileges to the SSSD user, minimizing the amount of code that runs as root.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a913cc9c8..f0a427254 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2498,7 +2498,9 @@ ldap_child_SOURCES = \
src/util/atomic_io.c \
src/util/authtok.c \
src/util/util.c \
- src/util/signal.c
+ src/util/signal.c \
+ src/util/become_user.c \
+ $(NULL)
ldap_child_CFLAGS = \
$(AM_CFLAGS) \
$(POPT_CFLAGS) \