summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2015-05-21 13:20:35 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-05-26 15:10:56 +0200
commit62b20154899f847e760d6dfbae6a32fb45b448de (patch)
tree00542b897c2e8762f1a583f301a93f485257c04f /Makefile.am
parentcc98e19b424861c2a7fd91e0d657d82c1dbf3059 (diff)
downloadsssd-62b20154899f847e760d6dfbae6a32fb45b448de.tar.gz
sssd-62b20154899f847e760d6dfbae6a32fb45b448de.tar.xz
sssd-62b20154899f847e760d6dfbae6a32fb45b448de.zip
SSSDConfigTest: Use unique temporary directory
Test SSSDConfigTest is executed twice with make check if python2 and python3 are available. Tests are executed in parallel with new automake and therefore it caused sometimes failures e.g. ERROR: testModifyExistingConfig (__main__.SSSDConfigTestValid) ---------------------------------------------------------------------- Traceback (most recent call last): File "/tmp/sssd/src/config/SSSDConfigTest.py", line 215, in testModifyExistingConfig mode = os.stat(of)[ST_MODE] FileNotFoundError: [Errno 2] No such file or directory: '/tmp/testModifyExistingConfig.conf' Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 80ed38de4..322f49887 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1290,6 +1290,7 @@ endif
# Feature Tests #
#################
TESTS_ENVIRONMENT = LDB_MODULES_PATH=$(abs_top_builddir)/ldb_mod_test_dir \
+ SSS_TEST_DIR=$(TEST_DIR) \
$(AUX_TESTS_ENVIRONMENT)
ldb_mod_test_dir: memberof.la