summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Cech <pcech@redhat.com>2015-07-08 07:17:28 -0400
committerJakub Hrozek <jhrozek@redhat.com>2015-08-31 18:30:19 +0200
commit11e8f3ecdddf8edd8b1bbe9f41b49ce8b709b92a (patch)
treecc5ae37861c5fb0efdb3e8dfd88bbdd543ab92b9 /Makefile.am
parentbdf422fde0fd6b40b3412bad3b200f8fd7ea8693 (diff)
downloadsssd-11e8f3ecdddf8edd8b1bbe9f41b49ce8b709b92a.tar.gz
sssd-11e8f3ecdddf8edd8b1bbe9f41b49ce8b709b92a.tar.xz
sssd-11e8f3ecdddf8edd8b1bbe9f41b49ce8b709b92a.zip
UTIL: Function 2string for enum sss_cli_command
Improvement of debug messages. Instead of:"(0x0400): Running command [17]..." We could see:"(0x0400): Running command [17][SSS_NSS_GETPWNAM]..." (It's not used in sss_client. There are only hex numbers of commands.) Resolves: https://fedorahosted.org/sssd/ticket/2708 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f153ab0ad..d4504aba3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -690,7 +690,9 @@ endif
pkglib_LTLIBRARIES += libsss_debug.la
libsss_debug_la_SOURCES = \
src/util/debug.c \
- src/util/sss_log.c
+ src/util/sss_log.c \
+ src/util/sss_cli_cmd.c \
+ $(NULL)
libsss_debug_la_LIBADD = \
$(SYSLOG_LIBS)
libsss_debug_la_LDFLAGS = \