summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2013-05-28 14:53:40 +0200
committerAndreas Schneider <asn@cryptomilk.org>2013-05-28 14:53:40 +0200
commita0a8ea66722ff75109eecb12a48b2487f103142a (patch)
treec5a622d83aeb69ee26c791b2b74ee6646d176eaf /tests/CMakeLists.txt
parent48d46cac3f21805eedc39a53cb224735c46ab77a (diff)
downloadsocket_wrapper-a0a8ea66722ff75109eecb12a48b2487f103142a.tar.gz
socket_wrapper-a0a8ea66722ff75109eecb12a48b2487f103142a.tar.xz
socket_wrapper-a0a8ea66722ff75109eecb12a48b2487f103142a.zip
tests: Add test as cmocka test.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..a93f450
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,9 @@
+project(tests C)
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMOCKA_INCLUDE_DIR}
+)
+
+add_cmocka_test(testsuite testsuite.c ${CMOCKA_LIBRARY})