summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 5 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 332ff96..b627b11 100644
--- a/setup.py
+++ b/setup.py
@@ -18,8 +18,9 @@ if __name__ == "__main__":
etcmodpath = "/etc/%s/modules" % NAME
initpath = "/etc/init.d/"
logpath = "/var/log/%s/" % NAME
- certdir = "/var/lib/%s/certmaster" % NAME
- pkipath = "/etc/pki/%s" % NAME
+ certdir = "/var/lib/certmaster/"
+ pkidir = "/etc/pki/%s" % NAME
+ libdir = "/var/lib/%s" % NAME
rotpath = "/etc/logrotate.d"
aclpath = "%s/minion-acl.d" % etcpath
setup(
@@ -31,7 +32,6 @@ if __name__ == "__main__":
license = "GPL",
scripts = [
"scripts/funcd", "scripts/func",
- "scripts/certmaster", "scripts/certmaster-ca",
"scripts/func-inventory",
"scripts/func-create-module",
],
@@ -51,20 +51,17 @@ if __name__ == "__main__":
"%s/minion/modules.netapp.vol" % NAME
],
data_files = [(initpath, ["init-scripts/funcd"]),
- (initpath, ["init-scripts/certmaster"]),
(etcpath, ["etc/minion.conf"]),
- (etcpath, ["etc/certmaster.conf"]),
(etcmodpath, []),
(manpath, ["docs/func.1.gz"]),
(manpath, ["docs/func-inventory.1.gz"]),
(manpath, ["docs/funcd.1.gz"]),
- (manpath, ["docs/certmaster.1.gz"]),
- (manpath, ["docs/certmaster-ca.1.gz"]),
(rotpath, ['etc/func_rotate']),
(logpath, []),
+ (libdir, []),
(certdir, []),
+ (pkidir, []),
(etcpath, []),
- (pkipath, []),
(aclpath, [])
],
description = SHORT_DESC,