summaryrefslogtreecommitdiffstats
path: root/funcweb/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'funcweb/setup.py')
-rw-r--r--funcweb/setup.py69
1 files changed, 69 insertions, 0 deletions
diff --git a/funcweb/setup.py b/funcweb/setup.py
new file mode 100644
index 0000000..40e86ee
--- /dev/null
+++ b/funcweb/setup.py
@@ -0,0 +1,69 @@
+from setuptools import setup, find_packages
+from turbogears.finddata import find_package_data
+
+import os
+execfile(os.path.join("funcweb", "release.py"))
+
+packages=find_packages()
+package_data = find_package_data(where='funcweb',
+ package='funcweb')
+if os.path.isdir('locales'):
+ packages.append('locales')
+ package_data.update(find_package_data(where='locales',
+ exclude=('*.po',), only_in_packages=False))
+
+setup(
+ name="funcweb",
+ version=version,
+
+ # uncomment the following lines if you fill them out in release.py
+ #description=description,
+ #author=author,
+ #author_email=email,
+ #url=url,
+ #download_url=download_url,
+ #license=license,
+
+ install_requires=[
+ "TurboGears >= 1.0.3.2",
+ ],
+ scripts=["start-funcweb.py"],
+ zip_safe=False,
+ packages=packages,
+ package_data=package_data,
+ keywords=[
+ # Use keywords if you'll be adding your package to the
+ # Python Cheeseshop
+
+ # if this has widgets, uncomment the next line
+ # 'turbogears.widgets',
+
+ # if this has a tg-admin command, uncomment the next line
+ # 'turbogears.command',
+
+ # if this has identity providers, uncomment the next line
+ # 'turbogears.identity.provider',
+
+ # If this is a template plugin, uncomment the next line
+ # 'python.templating.engines',
+
+ # If this is a full application, uncomment the next line
+ # 'turbogears.app',
+ ],
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Framework :: TurboGears',
+ # if this is an application that you'll distribute through
+ # the Cheeseshop, uncomment the next line
+ # 'Framework :: TurboGears :: Applications',
+
+ # if this is a package that includes widgets that you'll distribute
+ # through the Cheeseshop, uncomment the next line
+ # 'Framework :: TurboGears :: Widgets',
+ ],
+ test_suite='nose.collector',
+ )
+