summaryrefslogtreecommitdiffstats
path: root/contrib/ruby/rubygem-cobbler.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/ruby/rubygem-cobbler.spec')
-rw-r--r--contrib/ruby/rubygem-cobbler.spec23
1 files changed, 20 insertions, 3 deletions
diff --git a/contrib/ruby/rubygem-cobbler.spec b/contrib/ruby/rubygem-cobbler.spec
index 2753370c..93523204 100644
--- a/contrib/ruby/rubygem-cobbler.spec
+++ b/contrib/ruby/rubygem-cobbler.spec
@@ -30,10 +30,20 @@ Provides Ruby bindings to interact with a Cobbler server.
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{gemdir}
-gem install --local --install-dir %{buildroot}%{gemdir} \
- --force %{SOURCE0}
+gem install --local --install-dir %{buildroot}%{gemdir} --force %{SOURCE0}
-for file in %{installroot}/examples/*.rb; do chmod +x $file; done
+chmod +x %{installroot}/examples/create_system.rb
+chmod +x %{installroot}/examples/has_distro.rb
+chmod +x %{installroot}/examples/has_image.rb
+chmod +x %{installroot}/examples/has_profile.rb
+chmod +x %{installroot}/examples/has_system.rb
+chmod +x %{installroot}/examples/list_distros.rb
+chmod +x %{installroot}/examples/list_images.rb
+chmod +x %{installroot}/examples/list_profiles.rb
+chmod +x %{installroot}/examples/list_systems.rb
+chmod +x %{installroot}/examples/remove_distro.rb
+chmod +x %{installroot}/examples/remove_image.rb
+chmod +x %{installroot}/examples/remove_profile.rb
%clean
rm -rf %{buildroot}
@@ -52,6 +62,13 @@ rm -rf %{buildroot}
%changelog
+* Wed Aug 13 2008 Darryl Pierce <dpierce@redhat.com> - 0.0.1-3
+- Added caching for the auth_token to prevent extraneous calls to login.
+- Reworked and refined how cobbler_collection fields are processed, adding
+ support for both array and has properties.
+- Rewrote the documentation for Cobbler::Base to make it easier to understand
+ how to extend it to support other Cobbler types.
+
* Wed Aug 13 2008 Darryl Pierce <dpierce@redhat.com> - 0.0.1-2
- Removed markup of cobbler.yml and a config file. Fixed a few small bugs
in the code for using it as a gem.