summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Eckersberg <jeckersb@redhat.com>2009-03-18 13:30:31 -0400
committerJohn Eckersberg <jeckersb@redhat.com>2009-03-18 13:44:30 -0400
commitfc94644e28f0af3ce765ec3f87138b264125dee0 (patch)
treec4a476f8e6f891c7c45e15d1ae0d7ea00e776c41 /setup.py
parentcd7c424c4870bdf1b93c43b9283b25fb803361eb (diff)
downloadcertmaster-fc94644e28f0af3ce765ec3f87138b264125dee0.tar.gz
certmaster-fc94644e28f0af3ce765ec3f87138b264125dee0.tar.xz
certmaster-fc94644e28f0af3ce765ec3f87138b264125dee0.zip
[certmaster] Documentation and cleanup for minion-to-minion
* Add man page for certmaster-sync * Symlink certmaster-sync into triggers for post-sign and post-clean (doesn't execute by default) * Add sync_certs setting to default certmaster.conf * Create the empty /var/lib/certmaster/peers directory
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8cf70eb..2a1fcdf 100644
--- a/setup.py
+++ b/setup.py
@@ -44,12 +44,14 @@ if __name__ == "__main__":
(manpath, ["docs/certmaster.1.gz"]),
(manpath, ["docs/certmaster-request.1.gz"]),
(manpath, ["docs/certmaster-ca.1.gz"]),
+ (manpath, ["docs/certmaster-sync.1.gz"]),
(rotpath, ['etc/certmaster_rotate']),
(logpath, []),
(certdir, []),
(etcpath, []),
(pkipath, []),
(aclpath, []),
+ ("%s/peers" % certdir, []),
("%s/sign/pre/" % trigpath, []),
("%s/sign/post/" % trigpath, []),
("%s/remove/pre/" % trigpath, []),