summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2008-02-07 12:52:44 -0500
committerMichael DeHaan <mdehaan@redhat.com>2008-02-07 12:52:44 -0500
commit5b2601a56907b02efc6567354fa051ef08d97b6f (patch)
tree4c08ebd8830a1656c03dc42bc1426358ee07bf40 /setup.py
parent697402da24ca930b3608359a61b9872fdddc62d9 (diff)
downloadcertmaster-5b2601a56907b02efc6567354fa051ef08d97b6f.tar.gz
certmaster-5b2601a56907b02efc6567354fa051ef08d97b6f.tar.xz
certmaster-5b2601a56907b02efc6567354fa051ef08d97b6f.zip
Changing func to certmaster in top level directories, also covered
certs directory, lots more to do.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 9 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index 332ff96..effe61e 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from distutils.core import setup
#from setuptools import setup,find_packages
-NAME = "func"
+NAME = "certmaster"
VERSION = open("version", "r+").read().split()[0]
SHORT_DESC = "%s remote configuration and management api" % NAME
LONG_DESC = """
@@ -26,14 +26,12 @@ if __name__ == "__main__":
name="%s" % NAME,
version = VERSION,
author = "Lots",
- author_email = "func-list@redhat.com",
- url = "https://hosted.fedoraproject.org/projects/func/",
+ author_email = "certmaster-list@redhat.com",
+ url = "https://hosted.fedoraproject.org/projects/certmaster/",
license = "GPL",
scripts = [
- "scripts/funcd", "scripts/func",
"scripts/certmaster", "scripts/certmaster-ca",
- "scripts/func-inventory",
- "scripts/func-create-module",
+ "scripts/certmaster-request",
],
# package_data = { '' : ['*.*'] },
package_dir = {"%s" % NAME: "%s" % NAME
@@ -41,26 +39,18 @@ if __name__ == "__main__":
packages = ["%s" % NAME,
"%s/minion" % NAME,
"%s/overlord" % NAME,
- "%s/overlord/cmd_modules" % NAME,
- "%s/overlord/modules" % NAME,
- "%s/minion/modules" % NAME,
- # FIXME if there's a clean/easy way to recursively
- # find modules then by all means do it, for now
- # this will work.
- "%s/minion/modules.netapp" % NAME,
- "%s/minion/modules.netapp.vol" % NAME
],
- data_files = [(initpath, ["init-scripts/funcd"]),
+ data_files = [(initpath, ["init-scripts/certmasterd"]),
(initpath, ["init-scripts/certmaster"]),
(etcpath, ["etc/minion.conf"]),
(etcpath, ["etc/certmaster.conf"]),
(etcmodpath, []),
- (manpath, ["docs/func.1.gz"]),
- (manpath, ["docs/func-inventory.1.gz"]),
- (manpath, ["docs/funcd.1.gz"]),
+ (manpath, ["docs/certmaster.1.gz"]),
+ (manpath, ["docs/certmaster-inventory.1.gz"]),
+ (manpath, ["docs/certmasterd.1.gz"]),
(manpath, ["docs/certmaster.1.gz"]),
(manpath, ["docs/certmaster-ca.1.gz"]),
- (rotpath, ['etc/func_rotate']),
+ (rotpath, ['etc/certmaster_rotate']),
(logpath, []),
(certdir, []),
(etcpath, []),