summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorosmiy <osmiy@97f52cf1-0a1b-0410-bd0e-c28be96e8082>2007-07-03 13:27:18 +0000
committerosmiy <osmiy@97f52cf1-0a1b-0410-bd0e-c28be96e8082>2007-07-03 13:27:18 +0000
commit47322761508080983273ad33f8edeb065d999ecc (patch)
tree0da1057db0231b9e503b6d80e156fd3df00f8b6c /configure.in
parentc3fafe63847c8ae87162cd63b518660ad5681d2f (diff)
downloadzabbix-47322761508080983273ad33f8edeb065d999ecc.tar.gz
zabbix-47322761508080983273ad33f8edeb065d999ecc.tar.xz
zabbix-47322761508080983273ad33f8edeb065d999ecc.zip
- fixed ODBC monitoring (Eugene)
- added selfvalidation code for functions with variable argument list (Eugene) git-svn-id: svn://svn.zabbix.com/trunk@4419 97f52cf1-0a1b-0410-bd0e-c28be96e8082
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 175bfadc..c9d406d4 100644
--- a/configure.in
+++ b/configure.in
@@ -415,6 +415,19 @@ AC_DEFINE(HAVE_SYSINFO_TOTALRAM,1,[Define to 1 if 'sysinfo.totalram' exist.])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
+dnl Check for __VA_ARGS__
+AC_MSG_CHECKING(for __VA_ARGS__)
+AC_TRY_COMPILE(
+[
+int test(const char *fmt, ...) { return 0; }
+],
+[
+#define TEST(fmt, ...) test(""fmt, ##__VA_ARGS__)
+TEST("%s","test");
+],
+AC_DEFINE(HAVE___VA_ARGS__, 1 ,[Define to 1 if __VA_ARGS__ available.])
+AC_MSG_RESULT(yes),
+AC_MSG_RESULT(no))
dnl Check for sharedram in struct sysinfo
AC_MSG_CHECKING(for sharedram in struct sysinfo)
AC_TRY_COMPILE([#include <sys/sysinfo.h>],