summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb6917d..3ecbfdd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,9 +1,14 @@
cmake_minimum_required(VERSION 2.6)
project(libresample)
+
include(CheckIncludeFiles)
+
check_include_files(inttypes.h HAVE_INTTYPES_H)
+
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/configtemplate.h ${CMAKE_CURRENT_BINARY_DIR}/src/config.h)
+
add_library(resample SHARED src/filterkit.c src/resample.c src/resamplesubs.c)
set_target_properties(resample PROPERTIES VERSION 1.0 SOVERSION 1)
+
install(TARGETS resample LIBRARY DESTINATION ${LIB_INSTALL_DIR})
install(FILES include/libresample.h DESTINATION ${INCLUDE_INSTALL_DIR})